Support » Plugin: BulletProof Security » Adding plugins

  • Resolved Jon123456


    I installed BPS Pro, then tried to reactivate W3 Total Cache. It came up with this error:

    /home/accezz/public_html/wp-config.php could not be written, please edit config and add:
    define(‘WP_CACHE’, true); before require_once(ABSPATH . ‘wp-settings.php’);

    Is that something to do with file locking? If I want to update plugins or themes, or activate them, do I have to turn something off?



Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author AITpro


    Please see this BulletProof Security Pro Forum Topic for the answer >>>

    Great, I will get to it. Thank you. Fast support.

    I tried to unlock my root htaccess file and wp-config.php file. The root wp-config.php file unlocks, but not the .htaccess file. In in the CGI permissions & status table, it still says:

    Root .htaccess
    404 – Locked – Read Only

    Can you help?

    I just noticed that at the top of the screen it says that the root access file is not locked.

    But I can’t get W3 Total Cache to redeploy to the root htaccess file. It says that the Root htaccess file must be temporarily unlocked.

    So, two things effectively saying it is locked, another message saying its locked. Think there is a bug somewhere.

    Using FileZilla, I can see that the chmod is:

    htaccess 404
    wp-config.php 644

    Can I use FileZilla to change htaccess to 644 and then I can do the redeploy? Does locking the file essentially mean changing the chmod to 644?

    Plugin Author AITpro


    Actually i think this is the scenario that has occurred. W3TC wrote/added its .htaccess code to your root .htaccess file and the root .htaccess file was sent to Quarantine and autorestored because BPS sees that the file was modified. Do you see an .htaccess file in Quarantine? it will be named auto_.htaccess, but is your root .htaccess file if you look at the restore path. Select the checkbox for this file and click Restore File.

    At some point i will force the coding check for the file lock check to do a page refresh. What happens is you lock the root .htaccess file and that function completes and displays the text message that goes with that function. So what this means is you are seeing a text message for the last function and not the current status. That is why i added the additional blue text “file is locked or unlocked” text message.

    Plugin Author AITpro


    Also when the root .htaccess file is autorestored it is automatically locked again. 😉

    Under Quarantine, it says No Files in Quarantine. There is nothing in the Quarantine Log either. The directory wp-content/bps-backup/quarantine/ is empty too.

    And as I said, on the F-Lock page, there is a message saying the Root htaccess file is locked and also a message saying it is not locked, which obviously conflicts.

    Plugin Author AITpro


    Are you referring to DR or the GWIOD checks? these should be turned off for standard WordPress sites. Please click the Blue Read Me help button for additional info on what and who these checks are for. If you have a GWIOD site then this could actually be the problem.

    Ok do these steps.
    1. deactivate the W3TC plugin
    2. turn off autorestore
    3. unlock your root .htaccess file and wp-config.php
    4. activate the W3TC plugin
    5. go to the W3TC performance page and save all of your settings
    6. Go to autorestore and click all 4 Backup Files buttons
    7. lock your root and wp-config.php file (turn off GWIOD and DR checks in F-Lock unless you have a GWIOD WordPress installation)

    I did that before. However, this time I set DR and GWIOD to unlock and the root .htaccess file successfully unlocked. Before, one it left locked no matter what I did. Now, when I tried to lock it again it wouldn’t lock the Root .htaccess file.

    So, I turned all the options to Lock (including DR and GWIOD).

    Now it has locked root .htaccess and wp-config.php. However, I have got this error under GWIOD:

    GWIOD – Root htaccess file does not exist.
    0 – Unlocked or Not Locked

    GWIOD – Root index.php file does not exist.
    0 – Unlocked or Not Locked

    To be clear, now everything is locked except GWIOD. Can I just turn off those alerts? WordPress is installed in the root using a default type installation.

    Plugin Author AITpro


    Most folks do not have a GWIOD site so yes you would just turn those checks off. If you click on the Blue Read Me help button on the F-Lock page it explains what a GWIOD site is.

    I’ve done that now and I think everything is locked as it should be. Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Adding plugins’ is closed to new replies.