WordPress.org

Support

Support » How-To and Troubleshooting » Adding Pages Not Working?

Adding Pages Not Working?

  • I upgraded to 1.5 and was excited about the pages feature, but it doesn’t seem to work. I have friends with WordPress who can get it to work just fine.

    Basically, I go to Write Pages, make up some stuff to put there (tried making an about page), subimt, visit the URL (my_site/about), and it doesn’t work. Any ideas on what to do? Could it be my mod_rewrite settings?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Yes, if you don’t have your .htaccess file set to update automatically, you’ll need to copy the new rewrite rules each time you create a new page and update .htaccess accordingly.

    Ok, thank you. I thought so, because I could manually enter the page_id in a query string and it would work.

    If it interests you, with 1.5, WordPress can change your .htaccess for you. You simply need to make the file writeable by the server. Then you wouldn’t need to do it manually each time.

    I’ve tried adding new Pages – links show up on the main blog page – http://www.mysite.com/NewPage, but the new pages 404. I’ve just changed permissions on the .htaccess file to 666, but the pages still 404. What’s the next step I’m missing?

    Jumped the gun with the last post – I went back and changed the permissions to 766 on htaccess and that worked, all the new pages show up properly.

    Also: the codex instructions and other similar posts are confusing. Example from the codex:

    You must chmod the .htaccess file to 666 to edit it with the WordPress template editor, but this is not recommended, since if you do that, any user of your blog, who can edit templates will be able to edit it. You can change the permissions to 660 to make it server-writable, which again will have the same limitation.

    For a newb to WP, PHP, and so on, this seems to send a mixed message: “Fix your problem by changing .htaccess permissions to 666, but you put your site’s security (or at least its templates) at risk, so don’t do it.” Is a user somone who has posting priveleges, a visitor to the site, a commenter? Please, a little clarification. This kind of confusing language is pretty rare in the WP galaxy; I’m grateful for all the support posts, codex entries, and blogs that have helped me this far.

    Please post a comment to that article’s discussion page and hopefully someone will look into it. You can also post to the wp-docs Mailing List to ask for someone to clarify the article.

    WP seemed to be working fine on the CrossOver Online! web site.

    This morning, I created a new page, and it won’t show up. I went to edit the .htaccess file and it says I don’t have permission to edit the file. It won’t let me edit any file that I’ve tried.

    I’m guessing I’ve got a bigger problem than just not being able to post a new page. Any idea on what caused this and how to fix it?

    I’m supposed to be the only one with access to the site.

    The site itself (with the exception of the new page I tried to add) seems to work fine.

    Uh, never mind.

    For some reason, the change in permission to .htaccess didn’t stick – when I tried it again, it fixed everything.

    Rob,
    Setting 666 on any folder is extremely dangerous, don’t do it if you can at all help it. 666 is the attributes expressed in a numerical format, but essentially it means, 6– owner of the file can read and write (write also means delete!) -6- those in the users group can read and write –6 everyone else (the whole world, more specifically others) can read and write the file.
    4 = read
    2 = write
    1 = execute
    If you want to set read and write it’s 4+2 = 6, if it’s read, write and execute it’s 4+2+1 = 7. Read and execute is the highest that anyone you don’t trust should be allowed eg 4+1 = 5. However, on a web server it is not the actual “other” group that has anything to do with the files. I set mine to 755 with the user and the group set to my username. If the server *must* write to a file, I change the group to the name of the web server group, in my case apache and change permissions to 765 or something along those lines.
    Long story short, if you do change permissions on those files as recommended, change them back as soon as they are written.

    I’ve changed the permission to the wordpress directory (cmhod -R 777) and .htaccess file (chmod 666 .htaccess). Then WordPress automatically updated .htaccess for me. Nice!

    But my WordPress still can’t make any Pages for me. All I get is a 404 Not Found error message. Anyone got a clue?

    Could it be that I might now have mod_rewrite installed?

    For future readers. Ok, I solved the problem myself.

    My server didn’t load the .htaccess info, even thou i had mod_rewrite loaded

    I edited my http.conf file and changed AllowOverride variable to All instead of none. Violá!

    how do you edit the http.conf file?

    I have the same problem – new pages get a 404. My .htaccess file is writable but I still get 404s. What do I have to do?

    Help. Me. Now. Please!

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Adding Pages Not Working?’ is closed to new replies.
Skip to toolbar