Support » Plugin: Co-Authors Plus » Adding or changing author no longer working

  • Resolved Lethalmiko

    (@lethalmiko)


    When I create a new post, I cannot change the author to another one or add another author. Each time I search for an additional author or try to change author from myself to someone else, the search says “Sorry no matching authors found”. This happens even if I type out the name in full or try a partial match.

    I cannot edit authors even on old articles that are already published.

    The plugin was working fine as of Thursday two days ago. I use WordPress 5.7.

    • This topic was modified 1 month, 2 weeks ago by Lethalmiko. Reason: Additional information
Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Support Niels Lange

    (@nielslange)

    Hello @lethalmiko šŸ‘‹

    As the plugin hasn’t been updated recently, another theme or plugin must be causing the problem that you’re currently facing. I suggest that you deactivate all other plugins to test if the Co-Authors Plus plugin is working as expected.

    If the plugin is working again, you know that you’re facing a plugin conflict. In this case, you can activate all other plugins one by one while testing the Co-Authors Plus plugin after each plugin you activated. This allows you to see which of the plugins is causing the problems.

    If the plugin is still not working, even though you deactivated all other plugins, then you might be facing a theme conflict. In this, please switch to a default WordPress theme, such as the Twenty Twenty-One theme, to see if the plugin works again then.

    Hi @lethalmiko

    You could try revert back to the previous version. It works for me (3.4.3). And yes it does happen to me too. The search query dropdown doesn’t work properly but previous version works normal.

    And no there’s no custom functions. Only frontend styling that does effect the co-author plus looks on my theme child.

    • This reply was modified 1 month, 2 weeks ago by Quasimodo84.
    Thread Starter Lethalmiko

    (@lethalmiko)

    @quasimodo84, I tried your solution and it also worked for me immediately. I did not have to disable any other plugin. I have 70 plugins installed and the process of enabling one by one is rather tedious. When I tried it today, I could not find the offending plugin. I shall try again more slowly this time.

    Thanks a lot mate. You have saved my life today!! šŸ™‚

    Same problem (as lethalmiko) with my WP. I’ve been using the plugin for longer than a year with no problems. This morning (March 27, 2021), I upgraded to the latest version (3.4.4), and I cannot select a different author. Also, I went into phpMyAdmin, and edited the post manually, and it still won’t change! I cleared the cache. Don’t know what else to do. What’s up?

    The suggestion by quasimodo84 – to “revert back to the previous version” – how do you do that? I don’t see any options to select the version!

    Thanks

    Pance

    @wpuserca: Use “WP Rollback” Plugin to downgrade. It provides a “Rollback”-link for every plugin in the “Installed Plugins”-list, where you can select the version number you want to install (3.4.3). Very easy. Dont’t miss to disable automatic updates for “Co-authors Plus”, otherwise the problem might return when WP updates the plugin again.

    @quasimodo84: Thanks for the solution! Worked perfectly for me as well. No need to deactivate any other plugin.

    I hope the issue will be fixed soon. Maybe it’s related to changes in the WP 5.7 upgrade?

    Problem came from change of:

    $found_user = $this->get_coauthor_by( ‘user_nicename’, $found_term->slug );

    to

    $found_user = $this->get_coauthor_by( ‘user_nicename’, $found_term->name );

    Thread Starter Lethalmiko

    (@lethalmiko)

    @wpuserca , on the main plugin page on the right under the version number and tags, click on “Advanced View” and scroll to the bottom of the page. You will see downloads of previous versions.

    Also here: https://wordpress.org/plugins/co-authors-plus/advanced/

    From what I can tell, it appears that the latest WordPress update must be connected to this problem which only arose when I did a manual upgrade on Friday 26th March 2021.

    Same problem with our webpage. Will the plugin @nielslange tackle the (potential) issue as described by @giuliovale or better to revert to 3.4.3?

    Thanks!

    Plugin Support Niels Lange

    (@nielslange)

    Hello @lethalmiko, @quasimodo84, @wpuserca, @revilo2020de, @giuliovale & @andreasra šŸ‘‹

    I realized that my initial reply was a bit too quick. I just noticed that my colleague triggered a new release two days ago. I created an issue for this problem on https://github.com/Automattic/Co-Authors-Plus/issues/762 and will look into this the next days.

    Confirmed, same issue here. Roll back has worked as a temporary fix. looking forward to the issue resolution.

    @nielslange Thank you, Niels! šŸ™‚šŸ‘šŸ»

    RT Confirmed, same issue here. Rollback has worked as a temporary fix. looking forward to the issue resolution.

    Just here to say ‘me too’. *Some* authors still show, but many do not.

    Rolling back to 3.4.3 did not seem sufficient. Rolling back to 3.4 worked.

    Plugin Support Niels Lange

    (@nielslange)

    Hello @lethalmiko, @quasimodo84, @wpuserca, @revilo2020de, @giuliovale & @andreasra, @draivika, @ramsesm09 & @mastababa šŸ‘‹

    A few hours ago, we released version 3.4.5 which solved this reported problem. Sorry for the inconvenience and once updated, the plugin should work as expected again.

    Can confirm. 3.4.5 resolves it.

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.