Support » Fixing WordPress » adding new plug-in breaks plugins.php

  • Resolved Michael_onSaba


    I am stumped. I’ve been working on a new wordpress installation. Had a few pitfalls here and there, but have been get everything I want to do to work so far. Today, I installed a new theme, Weaver II Pro, and activated it. Everything seemed fine. I then installed a new plugin, UberMenu, but did not activate it immediately. When I tried to install another plugin, image-horizontal-reel-scroll-slideshow, the install stalled, or failed during or after upload. I just got a blank screen, no title, nothing. When I tried to view installed plugins, same thing, blank screen. The page stops loading, but everyting is blank. Viewing source is also blank, shows 1 empty line.

    Trying to troubleshoot I searched for solutions to this, found some simalar, but not exactly the same. Following advice I found that helped others, I checked my wp-content/plugins directory via FTP. The first plugin, UberMenu, was present, but not the latest one I tried to install. I first tried renaming the Ubermenu folder to “deactivate” it, even though I had not activated this plugin after install. No change. I then deleted the UberMenu plugin folder from the directory. After that, I could access plugins.php from the dashboard and see all my previously insatalled plugins. Throughout this, the site appeared to continue to perform normally.

    Deducing that UberMenu might have been the culprit, or perhaps corrupted during install, I tried installing the other plugin, image horizontal reel scroll. I tried installing internally from the wordpress plugin directory search. The plugin appeared to install. The INstall Plugin page loads, goes through the usual install steps, gives two links at the bottom “Activate PLugin” or “return to plugin installer”. If I click “activate”, I get a blank page. If I click “return to installer” I can go to the installer page, but if I try to view installed plugins, I get blank screen.

    I have tried several variations, installing from a downloaded .zip file, or from plugin search. No matter what, once I’ve installed a new plugin, I can no longer access plugins.php. If I delete the new plugin manually through FTP, I can then view the plugins page again.

    Thinking the new theme may have been conflicting, I switched back to the previous theme, same problem. Then I switched to Twenty-Eleven theme, still same problem.

    Why would I suddenly not be able to add any new plugins? I’m not done developing the page and still would like a few more plugins to make it complete.

    I am using WP 3.8.1 Any suggestions would be appreciated.


Viewing 5 replies - 1 through 5 (of 5 total)
  • I installed Image Horizontal Reel Scroll Slideshow and the Weaver II theme in my sandbox site. Both installed and activated without issue.

    I can’t test with UberMenu or the Weaver II Pro theme since they are both commercial products and as such not supported here. You’ll have to take up the issue with your vendors

    A deactivated plugin won’t be executed, so it can’t be the code inside a deactivated plugin that is causing a problem.

    What does happen in plugins.php is that every plugin – whether active or not – will have its header read by WordPress in order to generate the list of available plugins.

    The most likely scenario here is that you have an issue with the way your plugins are installed, rather than the plugins themselves; either there is a path issue, a corruption issue, or simply bad permissions on the plugin directories. For example, if you’ve uploaded with an FTP user in a different user group than your server user, the server may not be able to read those files.

    The best way to maximize your chances of installing the plugin properly are to upload through the WordPress plugin uploader. But if you’ve done that and it’s not working, the most common scenario is a permissions issue on your server.

    To see exactly what the issue is in order to diagnose it, you should enable debugging on your site

    Hope that helps 🙂


    Thanks for the feedback guys. Oddly, the problem solved itself. Shortly after submitting the OP, I tried one more thing. Having deleted all recently uploaded plugins, I tried installing yet another plugin, just randomly selected, and I was able to activate it and still access my plugins.php page. No errors, no blank page. So I tried installing to two plugins that I had previously had problems with. Both installed, still no problems. I’m still baffled. Don’t know if it was just some temporary server issue, or a corruption/permissions issue, but after two to three hours of not being able to install any plugins without this issue popping up, everything went back to normal.


    I experienced this issue as well. It almost seems if I have hit a limit … once I try to add one more plugin I am unable to refresh/view the plugins management screen (it doesn’t load). I can delete the recently added plugin directory via FTP and things return to normal.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘adding new plug-in breaks plugins.php’ is closed to new replies.