Support » Plugin: Asgaros Forum » Adding new menu links to the existing Forum menu

  • Resolved naomibuch

    (@naomibuch)


    Hi there,

    First I want to thank you for the wonderful plugin, I’ve tested a couple and that last Forum plugin “WPFORO” wasn’t mobile friendly and the support staff never had answers to my questions so I ended up deactivating that plugin.

    So my question is how to format and wrap the additional menu items where they are formatted properly on the Desktop this is the current code I have in my theme functions file:

    The closest I got to making it wrap in any type of format was using a pipe(|) and that shows up in the menu, and I am not that good at PHP coding.

    PS: I removed the links to my website to keep it from showing up on google search and replaced it with https://example.com.

    function my_menu() {
    
    echo   '<a href="https://example.com" class="center">Friends&nbsp;&nbsp</a>';
    
    echo   '<a href="https://example.com" class="center">Alerts&nbsp;&nbsp</a>';
    
    echo '<a href="https://example.com" class="center">|Classifieds&nbsp;&nbsp</a>';
    
    echo '<a href="https://example.com">Listings&nbsp</a>';
    
    echo '<a href="https://example.com">Chat&nbsp</a>';
    
    echo '<a href="https://example.com">Messages&nbsp</a>';
    
    echo '<a href="https://example.com">Reviews&nbsp</a>';
    
    echo '<a href="https://example.com">Testimonials&nbsp</a>';
    
    echo '<a href="https://example.com">News&nbsp</a>';
    
    echo '<a href="https://example.com">Google&nbsp</a>'; 
    
    }
    
    add_action('asgarosforum_custom_header_menu', 'my_menu');
    
    

    Thanks a bunch

    Naomi

Viewing 1 replies (of 1 total)
  • Plugin Author Asgaros

    (@asgaros)

    Hello @naomibuch

    Sorry for the late reply! Your code is looking fine so far. I am not exactly sure if I understand the problem correctly. Do you want to add a separator (|) or is it not showing correctly? Normally it should be displayed automatically. It would also be great if you could provide a screenshot so I can get a better idea about the issue! 🙂

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.