• Resolved paprika27

    (@paprika27)


    I installed the plugin, then changed the language of the page to DE. The settings of the plugin remained English and, much more importantly, the frontend still reads “Toggle High Contrast” etc.
    So I went into the translator area to download the stable .mo. I renamed it to wp-accessibility-de_DE.mo and moved it to the plugin’s lang folder. Still, frontend as well as backend remain english. What am I missing and why is there no documentation on how to apply a translation?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Joe Dolson

    (@joedolson)

    I’m not sure what you mean by ‘changed the language of the page to DE’.

    The site language for WordPress is managed at WordPress > Settings > General > ‘Site Language’; WP Accessibility would respond to that setting.

    Thread Starter paprika27

    (@paprika27)

    what you wrote is exactly how I changed the language of the page.

    yes, it should but it does not. Im assuming the reason is that while WordPress is available in de_DE, the plugin folder lang does not have any de files.
    And Im assuming that this is due to the incomplete translation. I really only care about the two front end strings so I want to have the incomplete translation anyway but don’t know how.

    • This reply was modified 5 years, 8 months ago by paprika27.
    Plugin Author Joe Dolson

    (@joedolson)

    According to https://de.wordpress.org/plugins/wp-accessibility/, German is already one of the shipped languages with WP Accessibility; there shouldn’t be any need to load it into the /lang directory.

    There are multiple versions of the core German translation in WordPress; which one did you change to?

    Thread Starter paprika27

    (@paprika27)

    I just downloaded the plugin from the german wordpress org page. Just like the one I downloaded from within my backend, the folder lang contains no de .mo

    I changed wordpress to “Deutsch (Sie)”, which, granted, has a smaller completion level than “Deutsch”. Is there the “Deutsch” .mo for your plugin which I can add to my “Deutsch (Sie)” translation? I had hoped I would be able to get the current translation of your plugin as a .mo file and could dump it into the lang folder. Maybe it needs a different name to be applied?

    Thanks!

    • This reply was modified 5 years, 8 months ago by paprika27.
    Plugin Author Joe Dolson

    (@joedolson)

    None of the translations listed as being complete translations in WordPress.org should appear in the /lang directory. That directory holds only the legacy translations as long as they are less complete than the translations found on WordPress.org.

    Languages that are shipped with plugins will be found in /wp-content/languages/plugins/. WordPress only downloads the languages that you have downloaded for WordPress core (found at /wp-content/languages/), and not all languages available.

    Does that help at all?

    Thread Starter paprika27

    (@paprika27)

    Joe, thanks, that helps!

    So, in order to get WP-Accessibility in a WordPress set to “Deutsch Sie” to be in German I should not dump the incomplete translation from the wordpress translation site into the plugins lang folder. Instead, I should grab the complete translation from the folder /wp-content/languages/plugins/wp-accessibility of a WordPress set to “Deutsch” and put it in the same place in my “Deutsch Sie” WordPress.

    This seems so extremely combersome for just two frontend strings. I’ll try anyway.

    EDIT: Setting WordPress to “Deutsch” does not cause a wp-accessibility_DE.mo to appear in /wp-content/languages/plugins/. So I can’t copy it to the same place in my “Deutsch Sie” wordpress. Do I need to manually trigger it to download language files for plugins?

    EDIT2: Ok, under dashboard>updates it offered me to download additional translations for my WordPress set to “Deutsch”. I did so, mo and po files for your plugin appeared at /wp-content/languages/plugins/. I renamed them to ~_formal and switched my wordpress back to “Deutsch Sie”. Now all is as I expected it to be at the get-go. Thanks for the decisive aid!

    • This reply was modified 5 years, 8 months ago by paprika27.
    • This reply was modified 5 years, 8 months ago by paprika27.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘adding .mo to lang seems to have no effect’ is closed to new replies.