Support » Plugin: 12 Step Meeting List » Adding Meeting Issue

  • Resolved interactivewestcom

    (@interactivewestcom)


    We have successfully added this meeting to 12 Step Meeting Plugin, however, City appearing is Delta but should be Olatha. Meeting is showing correctly on Mapbox Map in Olathe however the city is displaying Delta in location.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author tech2serve

    (@tech2serve)

    This appears to be an issue with Google Maps. When I use their search engine with the address in question I see where it is showing both Delta and Olathe.

    Based on my testing, mapping on the website for the meeting works correctly, but not in the app. I agree with your note to point people to the correct city.

    Unfortunately, this is not an issue with the plugin, and there isn’t really anything simple I can do to help you. I am going to research things a little bit more, but I suggest you contact Google and tell them the error shown on the Google maps page linked above.

    Plugin Author tech2serve

    (@tech2serve)

    I just took the address of 115 Main St, Olath, CO, (yes, misspelled the city) and entered it into my test platform. Google appeared to return the correct address, and it is showing correctly on my page.

    But, having seen the city shown incorrectly as Delta on Google’s own page confirms there is an issue with their database. I’ll still try to gather more information for you to take to them.

    Plugin Author tech2serve

    (@tech2serve)

    @interactivewestcom,

    Here is the evidence that might help with Google. I’ve created a pastebin link for you to pull up the details from Google’s database when doing a Place Autocomplete, similar to how the plugin works.

    Search the text and you’ll find a Description field that ties the address to Delta, CO, and one for KS.

    I’m still looking at options for why Google is getting confused (and hence the plugin) but I don’t have that yet.

    Here is an image of the confusion at Google.

    And here is a photo inside the plugin on my test site that shows the address as Delta, CO, and yet the map shows the location in Olathe, CO. A bit bizarre.

    • This reply was modified 1 month ago by tech2serve.
    • This reply was modified 1 month ago by tech2serve.
    • This reply was modified 1 month ago by tech2serve.
    Plugin Support brianwarea24

    (@brianwarea24)

    I agree that @tech2serve is on the right track, that you should contact Google to try to get this address corrected. That’s the best long term solution.

    In the short term, you could put the following code into the functions.php file of your theme. I’m not sure, but I think you’ll need to add this again each time you update your theme.

    
    /*
     * Adjust and address for the 12-Step-Meeting-Plugin until we can get
     * it fixed in Google.
     */
    if (function_exists('tsml_custom_types')) {
        tsml_custom_addresses(array(
            '115 Main St, Olathe, CO 81416, USA' => array(
                'formatted_address' => '115 Main St, Olathe, CO 81416, USA',
                'city' => 'Olathe',
                'latitude' => 38.606891,
                'longitude' => -107.9876138,
            ),
        ));
    }
    

    Then enter the address as exactly:
    115 Main St, Olathe, CO 81416, USA

    This should override Google, for now, and the address should work. You may need to adjust the lat/long if the pin isn’t in the correct location. I modified this code for this address from one that was in the readme.txt file of the tsml plugin.

    Plugin Support brianwarea24

    (@brianwarea24)

    Looks like I might have the wrong zip code in my example. If you use the code, change the zip code twice in the code, and also in the address you put in for the meeting. Just be sure that they all match.

    I am having a similar issue. I type in the address with the correct city, Belton and it gets auto updated to city of Bell. The map is correct (I am using mapbox, not google.)

    The address I type is:
    3003 N Main St, Belton, TX 76513

    The textbox changes to:
    3003 N Main St, Bell, TX 76513, USA

    I see that google pulled up the wrong city name in one place too, I am assuming mapbox uses google now. I reported the issue to google. Seems a little weird we can’t override these problems, we need to be able to make sure the address is entered correctly so it shows up not only on our website, but on the worldwide app correctly. I don’t like to have to publish a wrong city until a 3rd party like google fixes it…

    • This reply was modified 4 weeks, 1 day ago by sirbasku.
    Plugin Author tech2serve

    (@tech2serve)

    Does this error also get produced when only using the Google Maps page in a browser? If so, I’m still thinking it is an issue with Google’s database.

    But, it wouldn’t hurt for us to look closer at the plugin and make sure something hasn’t broken.

    Thanks for the heads up.

    sirbasku

    (@sirbasku)

    When I search the correct address in google maps, the search field still contains the correct address I searched for, “3003 N Main St, Belton, TX 76513, USA”, however under the picture it returns of the address is the wrong city:
    3003 N Main St
    Bell, TX 76513

    I tried to submit a correction to google. I am unsure of how to test in mapbox outside of the plugin, mapbox seems to try to take me to a map making interface.

    Plugin Author tech2serve

    (@tech2serve)

    Mapbox is only used to provide maps of the meetings AFAIK. Only Google is used to looking up the addresses when entering a new meeting.

    Have you tried the tsml_custom_addresses suggested above by @brianwarea24 as a short term fix?

    I saw that workaround, since the map is actually showing the right location I am not going to add code to the site just for that one google mistake for now, I’d rather the real mistake gets addressed. I have requested the address change through google maps (I think, their response said “Thanks for adding an address”) so I hope they get it straightened out. But thanks for pointing that out to me!

    • This reply was modified 3 weeks, 5 days ago by sirbasku.
    interactivewestcom

    (@interactivewestcom)

    I was able to resolve this overnight by adding custom php code to functions.php file that tech2server came up with. Sorry to followup later than I would like but PHP Programmer was out of town attending a funeral for one on his friends relatives.

    Gene Fourney
    InteractiveWest
    303-748-7250

    Plugin Author tech2serve

    (@tech2serve)

    No problem @interactivewestcom. I’m glad @brianwarea24’s solution worked.

    I would still suggest notifying Google as perhaps they’ll fix their database/display issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.