Adding media broke in 2.6.3 (2 posts)

  1. WillemGrooters
    Posted 6 years ago #

    I'm running into these problems since upgrading to 2.6.3:

    Warning: Compilation failed: this version of PCRE is not compiled with PCRE_UTF8 support at offset 0 in /sysblog/wp-includes/compat.php on line 94

    Warning: array_slice(): The first argument should be an array in /sysblog/wp-includes/compat.php on line 95

    Warning: implode(): Bad arguments. in /sysblog/wp-includes/compat.php on line 96

    I find this happening in several places:
    * Admin page, Incoming links (but only if these exist)
    * AFTER uploading a file (add media), or when adding media (images) to a post., no matter what panel. Upload itself is Ok, it's just after the update in the Choose, Gallery and Media library panels.

    Obviously, the PHP-engine I use misses this bit built-in, but it has never been a problem before; All WP versions I used before, up to 2.6, don't care. It's just 2.6.3 that happens to have a problem here.

    How to get around the problem?
    Or better, could WP follow a different execution path if UTF-8 is not built-in?

  2. WillemGrooters
    Posted 6 years ago #

    Well, found one thing, and that solved that problem: BLOG_CHARSET = UTF-8. Changed that and that problem seemed to be solved. But now adding medai doesn't return to the page...

Topic Closed

This topic has been closed to new replies.

About this Topic