Support » Plugin: IP Geo Block » Adding IPv6 to white list

  • Resolved benpaddlejones

    (@benpaddlejones)


    Hi
    I just started using this plugin and on my site the local IP is IPv6 so I want to make sure it is white listed, when I add the address and save it removes the colons “:” from the address.

    Also can I ad a range say 192.* ?

    Ben

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @benpaddlejones,

    Sorry about this issue. I found it’s a bug. Then I’ll fix it within a few days.

    And you may be within a LAN, so you expect this plugin to handle some private IP addresses.

    For the time being until I fix this bug, please follow the steps to keep using this plugin:

    1. At “Country code for matching rule”, put ZZ into text box.
    2. At “Local database settings”, uncheck all the APIs except “Maxmind” and “IP2Location”.
    3. Save sattings.

    ZZ means “Unknown country” which rarely happens unless the IP address is private.

    And if you cut the step 2., you’ll be forced to wait until you get all the results (= ZZ) from those APIs.

    Also can I ad a range say 192.* ?

    Sure. You can put 192.0.0.0/24 into “Whitelist of extra IP addresses prior to country code”. Please refer to https://en.wikipedia.org/wiki/Reserved_IP_addresses for private network.

    Thanks for your report!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Fixed in 2.2.9.1.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Adding IPv6 to white list’ is closed to new replies.