Adding images (5 posts)

  1. cmdai
    Posted 8 years ago #

    Uploading of images through the WP system rather than ftp (WS-FTP Pro).

    By the first upload a new directory should be created. This happens, but I receive an error message saying the file has not been created and asking if the server can write to WordPress.

    Once the file is created no images can be transferred to that file, error message saying that it is not possible.

    Permissions set to 777 for Main File (WP), for wp-content and, once created, for Uploads.

    Anything else that needs changing to make this function work?

  2. Marcel Brinkkemper
    Posted 8 years ago #

    Setting permissions to 777 is an invite for hackers to take over your site. You could best talk with your host about permission problems.

  3. carsten_lin
    Posted 8 years ago #

    This can be caused by a lot of things. For example a SafeMode problem or a not writable temp directory on the webserver or the mod_security feature from the apache. Therefore it would be helpful to know the exact error message.
    In case it is because of the SafeMode: disable the "Organize my uploads into month- and year-based folders" function under Settings, Miscellaneous.

  4. cmdai
    Posted 8 years ago #

    macbrink: Thank-you, I know.

    carsten_lin.: I've tried with and without the sub-files and with the no_flash plug in installed too. With normal ftp (WS-ftp Pro) there is no problem, just with the internal direct transfer from PC to Server.

  5. Scarabus
    Posted 8 years ago #

    My problem isn't with getting images on my site. It's with getting my site to display the images. I've tried two approaches: (1) using the upload utility and (b) uploading via FTP and linking--both automatically and manually. In every case the uploading went flawlessly. But in no case were my images displayed. Not sure whether it's a WordPress problem or a server problem.

    [Note: This wasn't a problem until I updated from 2.5 to 2.5.1. But it's probably relevant that, with 2.5, one day I could use Ecto or MacJournal as a front-end...and next day I couldn't. That quick. However, I could still write in WP itself, and I could upload images via FTP, link them, and have them display. Once I updated to 2.5.1, however, I was SOL. Not only was I unable to display new images, but the previously displayed images disappeared. Nice problem for inquisitive problem-solvers, I'm sure; but ultra-frustrating for a guy who just wants to say "Hello, World!" Yeah. In times past, I did learn several computer languages. Programmers will recognize the allusion.]

    I'll share this both with the WP community and with my ISP. I want to stay with both, and I recognize there's a good chance that either I've screwed the pooch or my database has been corrupted. This is not about who's at fault, though, but about getting back in operation. Consequently, I'll hope for the best but in the meantime be looking for a "bail out and start over" alternative.


Topic Closed

This topic has been closed to new replies.

About this Topic