• Resolved skytthe

    (@skytthe)


    When I add a gallery in a page using the Gutenberg editor I get these messages in the top of the box:

    Warning: Creating default object from empty value in /var/www/markusminde.dk/dev/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/package.module.attach_to_post.php on line 820
    
    Warning: Invalid argument supplied for foreach() in /var/www/markusminde.dk/dev/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/module.nextgen_gallery_display.php on line 568
    
    Warning: Creating default object from empty value in /var/www/markusminde.dk/dev/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/package.module.attach_to_post.php on line 820
    
    Warning: Invalid argument supplied for foreach() in /var/www/markusminde.dk/dev/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/module.nextgen_gallery_display.php on line 568

    The gallery works fine on the page, but I dont know what the messages mean, and the should’nt be there either…

    Best regards
    Knud

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Imagely

    (@imagely)

    Hi @skytthe,

    Thanks for your report. Our developers will look into fixing these warnings into the upcoming update ( they have created an issue ticket for tracking it ).

    In the meantime, there’s a workaround that’ll help hiding the warnings – you can edit wp_config.php file and replace:

    define('WP_DEBUG', true);

    with these lines

    ini_set('display_errors','Off');
    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);

    Sorry for the inconveniences created

    • This reply was modified 2 months, 3 weeks ago by Imagely.
    Thread Starter skytthe

    (@skytthe)

    Thanks for quick reply, and for workaround 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.