Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos, Zenfolio and Instagram » Adding Gallery to Post using Photonic/SmugMug hangs

  • Resolved pdibello

    (@pdibello)


    I have configured two related sites to use the same SmugMug account, billericacatholic.org and reled.billericacatholic.org, with different API key/secret pairs (although I am not sure if I needed to).

    On billericacatholic.org I can successfully add and view SmugMug Galleries. On reled.billericacatholic.org, when I try to add a Gallery to a Post or Page, the creation process hangs after selecting SmugMug, and then “Photos from an Album”/Current User, presumably as it is preparing the list of albums.

    Interestingly enough, if I copy the “[gallery ]” string from a illericacatholic.org Post to a Post on reled.billericacatholic.org, it fetches and renders the album correctly! So, I think that I can infer that I am correctly connected.

    I have tried using the same key/secrets on both sites, but still billericacatholic.org allows me to insert a Gallery, and reled.billericacatholi.org does not. I have also turned on server logging, but there are no events in the log. I have deactivated and removed and re-added the plugin, but with no difference.

    I am using PHP 5.6.x from 1&1/IONOS, but do not know which precise version. I tried to move to 7.0, but other items failed, so I fell back to 5.6.x

    Are there any ideas as to what I should try next? I pray that I am not missing anything obvious.

    — Phil

    • This topic was modified 1 month, 3 weeks ago by  pdibello. Reason: Typos

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sayontan

    (@sayontan)

    This typically would happen if you have a conflict between Photonic and a different plugin, and that is interfering on the back-end. The way to confirm this would be to have your JavaScript console open when you are trying this.

    There is no problem in the connection between your site and SmugMug – it is just some sort of a plugin / settings conflict. I did notice that on your site’s front-end there are quite a few JavaScript errors that show up when I open the console – it is possible that those are present in the back-end.

    A few other possibilities are:

    1. Are you using authentication in SmugMug? If you are not, try deleting your authentication credentials from Photonic → Settings → SmugMug → SmugMug settings → Access Token (for Back-end / Server-side Authentication) and Photonic → Settings → SmugMug → SmugMug settings → Access Token Secret (for Back-end / Server-side Authentication). Also, try removing your API key and secret – Photonic bundles a key that should let you do everything apart from authentication.
    2. If the above doesn’t apply try disabling SSL verification via Photonic → Settings → Generic Options → Advanced → Turn off SSL verification in calls.
    3. Are you using Gutenberg? Or the “Visual” mode in the Classic Editor? Or the “Text” mode in the Classic Editor? Can you try using the third option?

    Creating a gallery the old-fashioned way using the shortcode is the last resort, if using the “Add / Edit Photonic Gallery” button in the Text mode of the Classic Editor doesn’t work.

    I removed the Access Token/Secret, and I removed the API Key/Secret.
    I could not check the option to “Turn off SSL verification in calls” because I got the error cURL error 7: Failed to connect to api.smugmug.com port 443: Connection refused”
    I am using Visual Mode with the Classic Editor.

    After all this, when I open the JavaScript console this is what I get …
    load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-position,underscor&load[]=e,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload&ver=5.2.1:8

    JQMIGRATE: Migrate is installed, version 1.4.1
    wp-tinymce.js?ver=4940-20190515:11 Deprecated TinyMCE API call: <target>.onPostRender.add(..)
    load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.2.1:8

    JQMIGRATE: Migrate is installed, version 1.4.1
    onloadwff.js:71 [Violation] ‘setTimeout’ handler took 56ms

    VM313:1 POST http://reled.billericacatholic.org/wp-admin/admin-ajax.php 500 (Internal Server Error)
    (anonymous) @ VM313:1
    send @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.2.1:4
    ajax @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.2.1:4
    n.<computed> @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.2.1:4
    window.photonicPostFlowData @ flow.js?ver=20190531-143314:26
    (anonymous) @ flow.js?ver=20190531-143314:405
    dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.2.1:3
    r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=5.2.1:3

    What do I try next?

    I can’t get to the place where I get the shortcode generated on reled.billericacatholic.org, I would need to do it on billericacatholic.org, and then copy/paste. Uggh.

    — Phil

    Plugin Author Sayontan

    (@sayontan)

    All the errors you have listed out point to plugin conflicts on the back-end. However, unlike plugin conflicts in the front-end, a back-end conflict is something that I am not very effective with helping.

    I am using Visual Mode with the Classic Editor.

    Try using the Text mode with the Classic Editor. The Visual Editor can have conflicts when another plugin tries to override a library etc., but the Text mode should have no such conflicts for the most part.

    I can’t get to the place where I get the shortcode generated on reled.billericacatholic.org, I would need to do it on billericacatholic.org, and then copy/paste.

    Not necessarily. Photonic was, for over 7 years, a plugin that operated with barebones shortcode insertion and there are several tools and guides that can help you with simply inserting a shortcode. E.g.:

    1. You can go to Photonic → Helpers and find all your album ids. If that doesn’t work, you can also take a look at SmugMug directly for your album ids (It does look like you need authentication, though). Once you have done that you can make use of the examples here and here to build out a shortcode. There are other links as well to help you with more documentation here and here
    2. Additionally you could try using Add Media → Photonic → SmugMug for a more vanilla interface to construct your gallery (you will still need the album ids from Photonic → Helpers).

    Regardless of any conflicts with Photonic, I think you need to get in touch with your theme’s author – the theme seems to be throwing up many JS errors on the front-end (just activate the JavaScript console on either of your sites). This will cause unpredictable behaviour with several plugins, not just Photonic.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.