Support » Fixing WordPress » Adding flash movie to page :: wysiwyg won’t accept embed tag

  • I’ve got a page in WordPress in which I am trying to embed a flash movie. What defies explanation is why the wysiwyg will not accept the <embed > tags. I copy/paste it in (using the HTML editor as well), but it is not saved to the page. However the <param > tags are saved.

    Has anyone encountered this problem

    <div><object width=”375″ height=”400″ align=”middle” id=”slideshow” codebase=”,0,0,0″ classid=”clsid:d27cdb6e-ae6d-11cf-96b8-444553540000″>
    <param value=”sameDomain” name=”allowScriptAccess” />
    <param value=”/images/photos/slideshow.swf” name=”movie” />
    <param value=”high” name=”quality” />
    <param value=”#ffffff” name=”bgcolor” />
    <embed src=”/images/photos/slideshow.swf” quality=”high” bgcolor=”#ffffff” width=”375″ height=”400″ name=”slideshow” align=”middle” allowScriptAccess=”sameDomain” type=”application/x-shockwave-flash” pluginspage=”” />


Viewing 5 replies - 1 through 5 (of 5 total)
  • Disable the WYSIWYG editor on your profile.

    Still the embed tag gets stripped out. Is this a “feature”?

    Hello greendesert.
    The reason why it gets stripped off is because the embed tag is not allowed anymore and wordpress knows this so it gets rid of it. Try something like this:

    ‘<object type=”application/x-shockwave-flash”
    width=”the width” height=”the hight”>
    <param name=”movie”
    value=”flashmovie-name.swf” />
    <img src=”flashmovie-name.swf”
    width=”again whatever width” height=”again whatever height” />

    If it doesn’t work, let me know either here or leave a comment in my blog at:
    you can see my flash hearder.swf working properly there, and passed validation as well.

    That doesn’t seem to be working for me. I get a flash of a broken image icon and then nothing.

    Hi miri,
    Can I have a look at your website?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Adding flash movie to page :: wysiwyg won’t accept embed tag’ is closed to new replies.