Support » Theme: GeneratePress » Adding data-pin-description to images giving errors

  • Hi,

    I am trying to edit the html code of my images so Pinterest can get more info out of them. I read everywhere that I should be writing data-pin-description=”a sentence about the picture” and data-pin-title=”a sentence with the title and keywords”.
    However where ever I add these I get errors, that says these are invalid content.

    This is an example of an image html I have:
    <!– wp:wp-recipe-maker/jump-to-recipe /–>

    <!– wp:image {“align”:”center”,”id”:17683,”sizeSlug”:”large”,”linkDestination”:”none”} –>
    <div class=”wp-block-image”><figure class=”aligncenter size-large”>Cauliflower Stew<figcaption> Cauliflower Stew</figcaption></figure></div>
    <!– /wp:image –>

    This is the html of an image from a different site that has the Pinterest info:
    <p><img class="lazyloaded" src="https://mommyonpurpose.com/wp-content/uploads/2019/09/82493935_488999308486220_189068600718393344_n.webp" alt="fear of pain in childbirth" width="600" height="1200" data-pin-description="fear of pain in childbirth - when I was pregnant and about to go into labor i was TERRIFIED of the pain of childbirth! I wish someone had just given me this amazing childbirth advice. " data-pin-title="The one thing I wish someone had told me about the pain of childbirth" style="" data-pin-url="https://mommyonpurpose.com/what-i-wish-i-had-know-about-the-pain-of-childbirth/" sizes="(max-width: 600px) 100vw, 600px" srcset="https://mommyonpurpose.com/wp-content/uploads/2019/09/82493935_488999308486220_189068600718393344_n.webp 600w,https://mommyonpurpose.com/wp-content/uploads/2019/09/82493935_488999308486220_189068600718393344_n-150x300.jpg 150w,https://mommyonpurpose.com/wp-content/uploads/2019/09/82493935_488999308486220_189068600718393344_n-512x1024.jpg 512w" data-ll-status="loaded"></p>

    Thanks in advance for your reply.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Leo

    (@leohsiang)

    Hi there,

    I can’t see how this would be a theme issue.

    Does the same error occur if you use a Twenty series WP theme to test?

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.