Support » Plugins » Adding Customizable Header breaks website. Now function file breaks it too

  • I tried adding the code for a custom header. It worked (sort of) and I uploaded a header.

    Then at the top of my website I get this warning:
    TDOMF ERROR: Headers have already been sent in file /home/content/g/i/b/gibsona1/html/test/wp-content/themes/Basic/functions.php on line 11 before session_start() could be called. This may be due to…
    Your current wordpress theme inserting HTML before calling the template tag “get_header”. This may be as simple as a blank new line. You can confirm this by using the default or classic WordPress theme and seeing if this error appears. You can also check your theme where it calls “get_header”.

    And if I try to edit any of the template files, I get this error:
    Warning: Cannot modify header information – headers already sent by (output started at /home/content/g/i/b/gibsona1/html/test/wp-content/themes/Basic/functions.php:11) in /home/content/g/i/b/gibsona1/html/test/wp-admin/theme-editor.php on line 62

    I deleted the code from the functions.php for the custom header, and just left the code for the widgetized sidebar, but now I keep getting this error even though it worked before I added the custom header coding. The only thing that fixes it is if I delete the functions.php file altogether, but then my sidebar isn’t widgetized.

    Here’s the link:

    Any help would be greatly appreciated.
    Thank you!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Adding Customizable Header breaks website. Now function file breaks it too’ is closed to new replies.