WordPress.org

Forums

Types
Adding another post type to a custom fields group, now children wont show those (2 posts)

  1. pers0n
    Member
    Posted 1 year ago #

    I'm on version 1.5.4 of Types

    I added another Post Type to a Custom Fields Group, however when I did it makes it so any child items that use that custom fields group no longer show any field but the title field. Did it delete my data? But not only that I can't enter any other fields but title now.

    So for example: I had Specialties and it was a parent to Specialty Types. So under Specialties I should be able to add more than just a type to one of those child specialty types, but ever since I added another post type to a custom fields group called Detail Fields it was shared with some other types (it had a image field and description field only which a lot of different types can use) well once I added another post type like Cars, well now children for anything will only show the title option.

    Hope that makes sense

    https://wordpress.org/plugins/types/

  2. pers0n
    Member
    Posted 1 year ago #

    I found the bug to be that '_wp_types_group_post_types' in the table wp_postmeta was not showing one of my custom post types for some wierd reason, once added, it began to work as it had before

    however that posttype will not show up in the list of Post Types for the Custom Fields Group, not sure why, its a valid posttype, maybe because its a child of another posttype but that shouldnt prevent it from showing up but could be part of the bug

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Types
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic