WordPress.org

Forums

[resolved] Adding a photo caption makes my pics go on separate lines (7 posts)

  1. FHQWeb
    Member
    Posted 2 years ago #

    I am trying to add four photos on a page in one row. When I put the photos onto the page they align just like I want them to. However, as soon as I add a caption to the photos WP forces them onto separate lines.

    They are all set to size full, align none.

    Can someone please help me?

    Here is the page. http://www.firehousequilts.org.php53-11.dfw1-2.websitetestlink.com/about-2

    I am HTML illiterate, but learning... I appreciate any help anyone can give me.

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    It looks like the problem is that the <div> that contains the image and the caption is not floated to the left:

    <div id="attachment_258" class="wp-caption alignnone" style="width: 157px">

    See the alignnone in the above code - it would need to say "alignleft". If there is a way to change that in your theme, that should fix it. If not, since you are using a commercial theme, you'll need to ask the developer for help with this kind of issue/modification.

  3. FHQWeb
    Member
    Posted 2 years ago #

    Thank you. I thought that align none was what I needed, but apparently not. It works now with the images on one line, although they are not centered in the margin, but I think I can live with that if I must... Unless you have a fix for that?

  4. WPyogi
    Forum Moderator
    Posted 2 years ago #

    They still look the same here... Did you save the changes (not just preview)?

  5. FHQWeb
    Member
    Posted 2 years ago #

  6. WPyogi
    Forum Moderator
    Posted 2 years ago #

    See if you can adjust the margins on the right side.

  7. FHQWeb
    Member
    Posted 2 years ago #

    I don't know how to do that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags