Support » Plugin: MultilingualPress » Adding a new page

  • Resolved alzie1

    (@alzie1)


    Hi!

    So I have only one site in my multisite. Now I have bought another domain and connected it to my hosting service. I have also added it to the WordPress > Sites. But how do I make the new domain contain the same content as my original website, so I can start translating it?

    Right now the new domain is empty.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author dinamiko

    (@dinamiko)

    Hi alzie1,

    You can create the a new site based on an existing one via Sites / Add New and then select the existing site in Based on site select. Doing so will create a copy of the original site including all the content.

    After new site is created you´ll need to map the domain to the new created site:
    https://codex.wordpress.org/WordPress_Multisite_Domain_Mapping

    Thanks,
    Emili

    Thanks for the answer @dinamiko! However, I cannot find this “Based on site” setting, where is it located?

    Note that I am using the free version.

    Any update? I’ve managed to make the “base on site” setting. I do also understand the mapping configuration that you sent.

    However, shouldn’t the new site show in the top left corner with the other sites after creating it? Or how do I finally access it so I can start editing and translating it?

    • This reply was modified 1 year, 5 months ago by alzie1.
    Plugin Author dinamiko

    (@dinamiko)

    Hi @alzie1,

    In order to see the new site in top left corner menu you need to add your user to that new site.

    Also with a super admin user you can go to My Sites / Network Admin / Sites and then rollover on a site and click Dashboard.

    Thanks,
    Emili

    Thanks @dinamiko.

    All of that works now. The only thing left is that the new site is completely empty even though I selected the “Based on site” to my main site.

    How come the new site is completely empty and what can I do?

    Plugin Author dinamiko

    (@dinamiko)

    Hi @alzie1,

    It means that copy site process (Based on site) did not worked correctly and content was not copied to the new site.

    – Did you received any admin error message when the copy site process finished?
    – Can you try to create a new site but unchecking Plugins Activate all plugins that are active on the source site checkbox?

    Thanks,
    Emili

    Hi buddy,

    Thanks for the feedback, it’s really frustrating 🙁

    1. No feedback, just that when I initially added the new site with the correct settings, I got the error message:
    The link you followed has expired.
    Please try again.

    However, when I then go back to “Sites”, I see that the newly added site is in the list, even if I got the error message once confirming it.

    2. I just tried to create the site without copying the plugins, and the process looked just the same (I get the error message but site is still created, then it is completely empty).

    I have searched online without finding anything regarding this issue, do you know what else can be problematic?

    Thanks Emili!

    Plugin Author dinamiko

    (@dinamiko)

    Hi @alzie1,

    The message The link you followed has expired. Please try again. does not come from MultilingualPress but from WordPress Multisite.

    The site is created but there is a problem in the creation process and is not created correctly.

    Can you please try to deactivate MultilingualPress and create a new site? we need to know first if you are able to create sites in WordPress Multisite correctly.

    If you can create sites correctly in WordPress Multisite, then activate MultilingualPress, create a new site and the take look at your server error log file to see if there is any error (error log file(s) are usually located in the root you hosting, otherwise you´ll need to ask to your hosting provider).

    If there are error messages related, please post them here but remove any path to the file(s), this is important for security reasons, so instead of:
    /some/path/to/some-file.php

    just post: some-file.php

    Thanks,
    Emili

    Hi @dinamiko,

    I tried de-activating MultiLingualPress and followed the same process, but it yielded exactly the same result.

    I also checked the error log file and nothing is created there in terms of creating a new site or the MultilingualPress plugin at all.

    I also tried adding this to .htaccess as I searched online that many people got the same error message when uploading themes, so I thought that the problem maybe occured when the cloning of the theme was made:
    php_value upload_max_filesize 64M
    php_value post_max_size 64M
    php_value max_execution_time 300
    php_value max_input_time 300

    But the problem still persisted. What other things could be wrong?

    Thank you sincerely.

    Plugin Author dinamiko

    (@dinamiko)

    Hi @alzie1,

    The problem could be related to a misconfiguration in your WordPress Multisite, hosting or domain(s).

    Thanks,
    Emili

    Thanks @dinamiko,

    Any suggestion in what end I could start investigating?

    @dinamiko ? 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Adding a new page’ is closed to new replies.