Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Add/Edit Form Not Working on Localhost

  • Resolved chrismendes

    (@chrismendes)


    Hi there,

    Are there any known issues with the plugin not working locally on a developer’s machine? I haven’t been able to find any documentation to this effect.

    When adding/editing a donation form, the only option field that appears is the Donation Option -> Set Donation/Multi-level Donation.

    Screenshot: https://www.croydonukip.org/wp-content/uploads/donation-error.png

    Neither of the subsequent options are displayed nor present in the DOM. There are no errors in the console. Reading suggestions from other threads, I have deactivated all plugins except Give and switched to the twenty fifteen theme. Still no joy.

    However, adding the plugin to the live environment works fine. But I would like to develop the theme for this functionality locally.

    Any suggestions?

    Chris Mendes

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @chrismendes

    We develop locally everyday, so shouldn’t be an issue. I’d try the following:

    1) Download the latest ZIP from our plugin page and make sure all the files are present locally
    2) Deactivate all other plugins, there may be a plugin conflict.
    3) Try switching to a default theme, there maybe a theme conflict

    Let me know how it goes. Thanks!

    @chrismendes I also had this exact same problem. Turned out (after deactivating and reactivating every plugin… of course the culprit was at the end of the alphabet!) it was being caused by User Role Pro. It didn’t automatically give administrators the ability to add new Give forms, for some reason.

    Thank you very much Matt for the reply.

    Unfortunately neither of those steps have led to a fix. I’ve re-installed the plugin, deactivated every plugin except Give, and switched to the twentyfithteen theme.

    The only complication I can think of is related to user roles and permissions as I have my own roles and permissions. However I have tried both the out of the box Give user roles (manager/worker/accountant), and also assigned all Give related permissions to my own user roles, and still no joy.

    Any further suggestions would be hugely appreciated.

    Chris

    Thanks Alice for the reply. I’m using the same or similar plugins, namely User Role Editor and Menu Editor Pro.

    However I’ve assigned every permission under the sun, including the Give related permissions, to my users, have also tried the out of the box Give roles (manager/worker/accountant), and it still fails to work 🙁

    Whereas on my live environment where I still have my own custom theme and plugins all activated, and custom user roles, it works fine.

    Chris

    Furthermore, I have just cloned the live environment website (where Give works fine) to my local environment and it still doesn’t work.

    Perhaps it is PHP/Apache environment related? Any thoughts would be greatly appreciated.

    Chris

    Plugin Author Devin Walker

    (@dlocc)

    Hey @chrismendes – what are you using to develop locally? Is your local site named give.dev by chance? I’ve seen some issue with creating a development site named that.

    Was previously just localhost:80 but have now re-installed my setup, I had a few other reasons to do so, now mydomain.local. Still no luck with Give. I use MAMP Pro to set up my local environment.

    As mention in my last comment, I’ve done a complete clone of the live site within which the Give plugin works just fine. So precisely the same theme/plugins/users/roles/permissions, the only difference is environment.

    I have however found a way to continue developing. I’ve created a page locally with the HTML generated by a Private page with the Give donation form on the live site. I can now work on styling it.

    Bizarre! But I much prefer Give than the other donation plugins I’ve tried so this glitch isn’t enough to put me off! 🙂

    Chris

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hey Chris,

    I believe it’s related to an issue we have with PHP 7.1 We have a fix that will be included in Give 1.8, but you can fix it manually for now if you like:
    https://github.com/WordImpress/Give/issues/1377

    Give 1.8 will be released within the next 7-10 days. Thanks!

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    In MAMP Pro you can downgrade to 7.0.13 and it’ll work fine as well. Either way will fix it.

    Works! Fantastic. Yes, downgrading to PHP 7.0.13 did the trick.

    Look forward to the update that resolves the issue in the latest version of PHP.

    Thank you very much for your assistance.

    Chris

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Glad to hear. If you’re enjoying Give and appreciate our support, we’d love a kind review from you here:
    https://wordpress.org/support/plugin/give/reviews/

    Thanks!

    Done. Thanks again.

    Chris

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Add/Edit Form Not Working on Localhost’ is closed to new replies.