Support » Plugin: Error Log Monitor » Added code to wp-config.php, but still doesn’t work

  • I get this error on the dashboard:

    Error logging is disabled.
    
    To enable error logging, create an empty file named "php-errors.log". Place it in a directory that is not publicly accessible (preferably outside your web root) and ensure it is writable by the web server. Then add the following code to wp-config.php:
    
    ini_set('log_errors', 'On');
    ini_set('error_log', '/full/path/to/php-errors.log');
    error_reporting(E_ALL);
    For reference, the full path of the WordPress directory is:
    /opt/bitnami/apps/wordpress/htdocs/

    …Even though I have already added that code to wp-config with the correct path. Any fix?

Viewing 1 replies (of 1 total)
  • Plugin Author Janis Elsts

    (@whiteshadow)

    The message “error logging is disabled” means that the log_errors configuration option is turned off. Since you did turn it on, there are several possibilities:

    • The code is incorrect. This seems unlikely since no-one else has reported an issue like this, but bugs can always happen. Double-check that you have added all three lines, and try changing 'On' to 1.
    • The code is in the wrong place. Normally, it should be placed before the /* That's all, stop editing! Happy blogging. */ line. If it’s at the end of the file instead, try moving it up.
    • Something turns off error logging after you have turned it on. Are you running any other plugins that are related to error logging or debugging? Check their configuration and make sure one of them isn’t set to disable logging.
    • The hosting provider doesn’t allow changing logging settings with ini_set(). Check their documentation – they might have a different process for turning on error logging.
Viewing 1 replies (of 1 total)
  • The topic ‘Added code to wp-config.php, but still doesn’t work’ is closed to new replies.