Support » Plugin: Fast Velocity Minify » Good support

  • Issues experienced with Uncode theme causing database to bloat.
    Developer offered helpful advice.

    • This topic was modified 2 months, 3 weeks ago by jtwoody.
    • This topic was modified 2 months, 3 weeks ago by jtwoody.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Raul P.

    (@alignak)

    It’s as shown on the help section… database will (only) grow if you are minifying files with dynamic content, or with dynamic file names. If the content is dynamic and changing on every pageview, its minified as unique and stored, as it should. In that case, you will get a new minified file on every uncached pageview.

    The options allow you to exclude them and have the plugin minify only the regular static files. Dynamic content cannot be minified, else it would minify on every page and slow things down.

    During optimization with FVM you need to understand how optimization works and manually decide what to do with that type of content. It’s not plug and play, it’s a manual optimization plugin.

    Thanks

    • This reply was modified 2 months, 3 weeks ago by Raul P..
    Thread Starter jtwoody

    (@jtwoody)

    Thanks for your reply but I had no dynamic content or file names.
    From WordPress update 5th September, dB went from 9.9Mb to 1.9Gb in 11 days.
    No settings were changed. On the verge of the site coming down.

    Plugin Author Raul P.

    (@alignak)

    Sorry to hear that. Can you share your url so I can take a quick look?
    Nothing really changed regarding the logic of the minification, so I am just curious how it could happen.
    Thanks

    Thread Starter jtwoody

    (@jtwoody)

    Plugin Author Raul P.

    (@alignak)

    It appears to be from the uncode theme, perhaps some customization done, or an intended update. The file names are static, but the query string is changing on every pageview.

    Take a look via google chrome dev tools, under the network tab.
    For example, these files (https://i.imgur.com/Y5fohtZ.png)

    /wp-content/themes/uncode/library/js/init.js?ver=375711253
    /wp-content/themes/uncode/library/js/plugins.js?ver=375711253
    /wp-content/themes/uncode/library/js/app.js?ver=375711253

    the query string (375711253) change on every pageview (just refresh and you can see it). https://i.imgur.com/65rE5re.png

    The query string changing will not only prevent any minification from doing the intended optimization for these files (the minification always sees a different, new file) but it also prevents browser caching for those files (even without minification).

    I suggest checking with your dev or perhaps the theme author (if it’s the original theme) on why they need dynamic query strings on those static files. Version numbers should be ideally tied to the plugin/theme version, not some random or other digit.

    Thanks

    Thread Starter jtwoody

    (@jtwoody)

    The theme isn’t customised. I’ll look into it and update review
    Thanks Raul

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this review.