Support » Plugin: bbPress - Moderation Tools » Add User Moderation Flag doesn’t work as expected

  • Hello,

    When i click the “Add User Moderation Flag” link next to a user all of the users in that topic get flagged. Outside that topic the user doesn’t get flagged.

    i think as the name says the user should get flagged for moderation for everything he writes not all users in the topic. Is this a bug or do I misunderstand the purpose of this link?

    The first screenshot shows the link that I click in order to flag a user for moderation:
    https://snag.gy/2cXHkz.jpg
    The second screenshot shows what happens after I clicked the link. All users of the topic are getting flagged for moderation:
    https://snag.gy/clWyXE.jpg

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter maxlevel

    (@maxlevel)

    I have seen that on the plugin page under features it says:
    + Flag individual users for moderation

    So this should be possible. is this the link “add user moderation flag” below the user image (https://snag.gy/2cXHkz.jpg) or is this set in another way?

    Plugin Author Digital Arm

    (@digital-arm)

    Yes that is the correct option.

    I have just tested this on a clean install with just bbPress and it seems to be working as expected. It does sound like a bug but I’m not sure what could be causing it.

    Have you tried disabling some other bbPress plugins to see if something could be causing a conflict?

    Thread Starter maxlevel

    (@maxlevel)

    After 5 hours tinkering I think I found the problem:

    The “Add user Moderation Flag” option does not work when I set “Reply Threading” to “Enable threaded (nested) replies 2 or more levels deep”.

    Without that checked everything works as expected.

    “Reply Threading” is an option in the Settings>Forums menu

    Thread Starter maxlevel

    (@maxlevel)

    I also tried that on a fresh install as well as on my site with all plugins turned off and standard WP Theme.

    Plugin Author Digital Arm

    (@digital-arm)

    Thanks for getting to the bottom of this! I’ve logged an issue so we can address this in a fututre update.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Add User Moderation Flag doesn’t work as expected’ is closed to new replies.