Support » Plugin: NP Quote Request WooCommerce » Add to quote button not displayed in another language

  • Resolved christhejok3r

    (@christhejok3r)


    Hi,
    i installed a woocommerce shop in german (main language) and english. My customer wanted to have a quote feature so i installed your plugin. It works fine for german. The button “add to quote” is visible and works. But when i switch to the english translation of the product detail page the button is not visible anymore.
    For the translation i installed WPML.

    Do you have any idea what i can do?

    Thank you
    Christian

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • christhejok3r

    (@christhejok3r)

    Hi,

    i found out what the problem was. WPML saves the translated product under another ID. So the settings to each product in the main language for RFQ is not stored for the translated products. I added the translated products manually to the postmeta table and now the button is visible.
    The next problem is that sometimes the products are not added to the quote list. I see the success message but the list is still empty. Sometimes this works but i cannot delete the product in the quote list.

    Any ideas?

    Thank you
    Christian

    Plugin Author Neah Plugins

    (@gplsaver)

    “sometimes the products are not added to the quote list”
    Make sure you exclude quote-request page from your cache. Also look in the error log and post it if you see any errors.

    christhejok3r

    (@christhejok3r)

    Hi,
    thanks. You’re right. WP Fastest Cache was the problem. I added excludes for the request and the product pages. Now it works fine…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Add to quote button not displayed in another language’ is closed to new replies.