Support » Fixing WordPress » Add to menu button fails to add custom link.

  • Presently having an issue with creating custom menu links on fresh domains with freshly installed versions of wordpress.

    Can create a custom menu, but cannot add any custom links to the menu. After clicking the “add to menu” button, the icon just spins and nothing happens.

    If the “automatically add pages” checkbox is selected, pages are added to the menu — so that works.

    Possibly worth noting:

    I have a reseller account with my webhost. WordPress custom menus work fine when installed anywhere on that primary domain ( — and I have 4 of them installed (and working fine) and another that I created as a test recently while troubleshooting this menu issue.

    Custom menus do not work on any other domains created by that reseller account (including a domain created the same day that reseller account was activated on the webhost) — so it doesn’t appear to be time related.

    This is with a clean install of wordpress (installed both manually and through fantastico) with no plugins activated on a freshly created domain account.

    What I’ve tried:

    • Have tried this on 4 separate domains, plus the working reseller domain
    • Different browsers (IE / chrome)
    • Clearing my browser cache
    • Rebooting (I’ve been troubleshooting this for 4+ days)
    • Installing via Fantastico
    • Installing manually
    • No plugins activated
    • Tried with default theme and other themes
    • I installed the “WordPress Menu Exporter” plugin. Then I exported menus/links from a working site and imported them to a non-working site. They imported just fine. I figured I could just edit the imported custom menu links and hit save… but saving doesn’t work (nothing happens).
    • File & directory permissions appear the same on the non-working sites as they do on the working one (as best as I can tell)

    Could this be a webhost issue? — And if so, any clues on the cause or how to fix it?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Discovered an exception:

    The “add to menu” button works on a .ORG account I have that I installed WP to in Jan 2011.

    So it works on the primary reseller domain. And 1 .ORG domain.

    But does not work on 4 recently created domains.



    Forum Moderator

    I think that this has to be a server issue. It’s not one that has been reported before to any degree. Have you checked your site’s error logs for clues?

    Webhost support has supposedly been looking into this for a couple days — and checking the site’s error logs for clues.

    But I haven’t gotten much information from them — so whatever it is, it’s not throwing up an obvious error.

    I continue to send them more info as I troubleshoot — such as what domains it works on and what domains it doesn’t.

    I’m with you — I suspect it’s a server issue, although I was hoping there might be some clues as to how to solve it on the server end.



    Forum Moderator

    This is a long shot but try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

    Just tried that and it didn’t change the behavior I’ve been getting, but I appreciate the suggestion.

    If/when I do get the issue resolved, I will report back what the webhost did to fix it in case anyone else runs into this issue.



    Forum Moderator

    Darn 🙁 Pull it out then.

    The only thing I can think of, server-wise – is that something is blocking POST requests. Could be an overly tightly configured firewall, perhaps? Definitely smacks of something related to the server’s security config.

    Thank you. I just passed that along!

    Just to report back, it was a server security settings issue.

    They relaxed the settings a bit and it allowed the “add to menu” button to work, but any attempt to save the menu would kick me out of admin and result in a 404 not found.

    So they relaxed the (navmenu.php) settings a bit more and that fixed it.

    Now we know.

    Thanks again for your earlier attempts at problem solving.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Add to menu button fails to add custom link.’ is closed to new replies.