Support » Plugin: Super Progressive Web Apps » Add to home screen on Chrome for Android not working

  • Hi, we followed the following steps in order to get the “Add to home screen” feature for our wordpress web site:

    – Updated to the latest versions all plugins, themes, and WordPres (OK)
    – SSL (OK)
    – WordPress v. 5.0.3 (OK)
    – Running PHP version: 7.0.32-1~dotdeb+8.1 (OK)
    – Plugin installed (OK)
    – Icons format: PNG (OK)
    – Icons size: 192px X 192px & 512px X 512px (OK)
    – WordPress cache purged (OK)

    Mobile device info on which we tried to instal the progressive app:
    – Android v. 7 (OK)
    – Chrome for Android v. 71.0.3578.99 (OK)
    – browser’s cache empty (OK)

    we tried to load the wordpress web site in the browser, but the “Add to Home Screen” button did not show.
    How can we fix the issue?

    Thanks.
    E.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hi,

    Can you please deactivate the OneSignal plugin upon your website and try it again?

    saintmalik

    (@saintmalik)

    Okay sir… But superpwa pop up are showing on Firefox… Will I be able to install back my onesignal plugin back

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    As from my knowledge there is no prompt like on Chrome browser over Firefox. A2HS works like on this video.

    Can you please activate the OneSignal plugin and check Status within our plugins settings panel to confirm whether the service worker can be seen or not?

    Looking forward.

    saintmalik

    (@saintmalik)

    Sir, after I activated one signal again with it… It stopped showing… What could be the main cause sir

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hi,

    When I looked into the URL I cannot notice the website loading other than the directory listing of files. Can you please let me know whether the website is still live or not?

    Looking forward.

    Yeah the site is now up…

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Cannot even notice our plugin is whether activated over the website. Can you confirm it?

    It’s reactivated sir… Please help me check

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Looks like the Registration of Service Worker is restricting by some code/plugin within the website. Can you please deactivate all plugins other than SuperPWA and try activating one by one?

    Okay… So how do I know the exact plugin by reactivating them on by one

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    1) Upon Chrome Browser for Windows > Inspect Element > select the Application tab

    2) Under Application > Select the Service Workers

    3) There you can notice a file if any service worker is registered.

    After activation of each plugin refreshes the Homepage, to know which plugin is restricting it.

    Hello sir… I couldn’t detect anything, please do help me check into my blog please sir

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hi @saintmalik

    I looked again into your website and noticed that the OneSignal key which you used is generated for a http website. Please do generate a new application key from the OneSignal and update it upon their plugin.

    You can also notice this same over the console.

    Looking forward

    I already set the https onesignal notification sir,, check through I still don’t see pop up

    ?? Sir, I set the https onesignal but the pop up is not showing

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Add to home screen on Chrome for Android not working’ is closed to new replies.