Support » Plugin: Super Progressive Web Apps » Add to home button doesn’t show

  • Resolved gurgaller

    (@gurgaller)


    I installed the plugin and I don’t see the button to add the site to the home screen.
    Also, when accessing any page of my site via a desktop, the following notice is logged to the console: “SuperPWA: Current page is excluded from cache”. What can the problem be? and how can I fix it?

    • This topic was modified 1 year, 5 months ago by  gurgaller.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hello @gurgaller

    Good day and thanks for using our Super Progressive Web Apps plugin.

    I noticed that you are using OneSignal within your website. Right now our plugin is not fully compatible with OneSignal.

    As for testing, you can disable OneSignal for sometime and test our plugin after clearing the browsing data.

    Hope it helps and looking forward to hearing your thoughts.

    Thank you! it is working now!
    I do want to see a OneSignal computability in the future, but the plugin is already awesome as it is:)

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Happy to hear that it worked well @gurgaller. We will make our plugin compatible with OneSignal hopefully by the next release itself.

    Glad to hear that you liked our well, hope you’ll support our small plugin 😉

    Hi,
    I have noticed that the “SuperPWA: Current page is excluded from cache” message is still logged to the console on every page of my website even after I turned OneSignal off, what is it?

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hello @gurgaller

    Good day! I just checked your website upon my device and I cannot find any such error within Google Chrome console. I think it may be due to earlier cache within your browser or because of the OneSignal’s Service Worker already registered. Can you please clear all the browsing data and test it again?

    chrome://settings/clearBrowserData or Ctrl+Shift+Del will help to clear browsing data upon Google Chrome

    Thanks, that was the problem:)

    Hi again,
    The problem is back:(
    The message still appears on certain pages like the /shop page.
    I tried from a different PC and from an incognito window, and it’s still there.
    I have tried to delete the cache from WP Rocket and it didn’t help too.
    Sometimes the message appears after a few seconds and not immediately.
    I really don’t know what can cause this, any ideas?

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Can you please let me know whether you’re using Cloudflare DNS?

    No, I’m not using it.

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Seems like your website is using Cloudlfare Nameservers (Reference)

    If yes, the issue that you noticed is because of the caching at Cloudflare. As for resolving this you can purge cache at Cloudflare and disable caching for sometime. It may take some time to get this reflected.

    I turned Cloudflare caching off a few hours ago and it’s still doesn’t work:(

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hello @gurgaller,

    I tested your website upon 2 desktops (on Google Chrome Browser), I cannot even notice any such error that you mentioned above. Can you please share the URL on which that you noticed the error? So that I can test that specific URL again.

    Just to chime in and follow this conversation, I see the same message on console (not an error, simply a console message).
    -Chrome
    -Running Genesis + child theme
    -WP super cache (may be the issue?)
    -LAMP stack on ubuntu (aliyun aka Alibaba)
    3aenglish.com

    • This reply was modified 1 year, 4 months ago by  lijitimit.

    In this page for example, the error appears after a few seconds.

    Plugin Author Jose Varghese 🚀

    (@josevarghese)

    Hello @lijitimit,

    Good day and thanks for using our plugin. As you mentioned, its not an error – we added “SuperPWA: Current page is excluded from cache” to Console log for easily troubleshooting.

    @gurgaller Within our plugin, we excluded the caching of URLs like /wp-admin/, /wp-login/ and /preview=true/. If any user be their on those pages (that’s /wp-admin/, /wp-login/ and /preview=true/) the above message will be logged to console for better understanding that the page is excluded from Cache. On some normal pages, contents are loaded or updated via ajax requests which are fetched from /wp-admin/admin-ajax.php.

    Due to that, ajax requests also comes under our cache exclude list. That’s the reason why you are noticing the Console message for some pages after some time interval. In this case only some requests are excluded from caching, not the entire page. We’ll update this Console Log message on our coming version by changing “pages” with “requests”.

    You can also validate whether the page is cached or not by going offline and refreshing the page. The same page will be loaded even if your are offline and if visited earlier.

    Hope you got more clear idea about the message.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Add to home button doesn’t show’ is closed to new replies.