Support » Plugin: Document Gallery » ‘Add to Document Gallery’ not working

  • I hadn’t realised that this plugin was no longer being maintained, but that’s my own fault for not paying attention. I tried modifying a document gallery for the first time in a while, and when I edit it and click on ‘Add to Document Gallery’ I get a pane with no media icons in it.

    I worked around it this time by finding out the new item numbers from the database and editing the dg shortcode manually. I think it was working okay until I updated to WordPress 5.3. I’m still using the classic editor.

    Does anyone have a code fix for this?

    Alternatively, anyone suggest what plugin to use instead? I guess I’m going to have to move one day soon, but haven’t found anything as good.

    Best wishes

    John

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have the same problem, cant add to an existing document – even when using the old editor. Also it seems to have broken the upload tab as well, so I cant upload without coming out of editor and going to the media library directly.

    Unfortunately I use DG in multiple places around the site, so this is a major pain. Any suggested alternatives would be welcome
    (WP 5.3.2)

    Not sure if it helps @bacasdev but I did a bit more research and I’ve found that the problem was caused by another plugin – Enhanced Medial Library by wpUXsolutions, which also has not been updated. I disabled this and, hey-presto, DG now works OK when used in a classic block or Pagebuilder block/widget.

    Thread Starter bacasdev

    (@bacasdev)

    Many thanks, @nymmkt . I am indeed using Enhanced Media Library as well, and disabling it worked for me too. So I now have a workaround.

    Glad to hear it – if you’ve not done so already then the “premium” version of “Media Library Categories” functionally replaces Enhanced Media Library and can pick up all of the EML categories.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘‘Add to Document Gallery’ not working’ is closed to new replies.