Support » Plugin: WooCommerce » “Add to Cart” results in empty cart on Edge browser

  • Resolved David Schwalbach

    (@david-schwalbach)


    Hello, I have a site that is running the most recent version of WooCommerce and have an issue when adding products to the cart. It says the product is added and updates the cart number on the navbar but when visiting the cart, there are no products there – the cart is empty.

    The issue is also only in the Edge browser. Is anyone else experiencing this or know of a way to fix it?

    Also running the Dazzling Theme if that helps

Viewing 7 replies - 1 through 7 (of 7 total)
  • Anyone else having this issue or know a fix? Thanks!

    Site is https://www.leaveonlybubbles.com

    Consider updating your parent theme to the latest, v2.1.0. I can’t say if the latest version includes a fix for this, but updating is a reasonable next step. Backup first.

    Well, I updated it to v2.1.0 and it did appear to work a bit better, but still not good enough.

    Adding new products updates cart value no matter what and the first time visiting the cart will show those products added, but going back to shop and add new items, does not show them in the cart page when re-visiting it. It’s also still impossible to remove some items from the cart.
    Still only having an issue with the Edge browser. Would this be a CSS issue?

    I should delete any cached pages and turn off Simple Cache until the problem is fixed.

    If the problem persists, deactivate all other plugins to be able to rule out a plugin conflict.

    Did you check the theme support forum for similar issues, and try posting there:
    https://wordpress.org/support/theme/dazzling

    The next step would be, with plugins still deactivated, to try another theme, virtue for example. If the problem resolves at this point, it would point to an issue with your current theme.

    I am unable to examine your site on the Edge browser because of the notice, but to be honest, I would be lucky to deduce anything from an Edge browser test.

    Doesn’t sound like a css issue. Cart data is supposed to be saved in cookies between page loads. Did you check cookies are enabled, and/or try either a reset/reinstall of your Edge browser, or try with the Edge browser on a another computer.

    Thank you for the help, I tested through the plugins and there seems to be a compatibility problem with the caching. I’ll have to look into this further but for now, the issue is resolved. Thanks!

    Has anyone found a solution yet? I’m experiencing the same problem, but only with Edge. All other browsers on both Mac and PC work just fine.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“Add to Cart” results in empty cart on Edge browser’ is closed to new replies.