Support » Plugin: WooCommerce » Add To Cart not working after upgrade

  • b747fp

    (@b747fp)


    All my Add To Cart buttons stopped working completely since i upgraded they just reload the product page and do not add to cart… tried completely re-installing the woothemes theme fresh download, tried deactivating/reactivating all plugins, still does not work. I am running WP MultiSite. No errors in javascript console…

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 13 replies - 1 through 13 (of 13 total)
  • b747fp

    (@b747fp)

    and yes, i’ve run the db update

    nwebstijl

    (@nwebstijl)

    I had the same problem, but it only showed up at variations.

    The problem was caused by the overriding WooCommerce files in my theme.
    I solved the problem in my theme by deleting the following folder “add-to-cart” in /wp-content/themes/my-theme/woocommerce/single-product/

    If you changed some files in the “add-to-cart” directory I suggest that you upgrade them to the latest version of the WooCommerce default files which can be found in /wp-content/plugins/woocommerce/templates/single-product/

    b747fp

    (@b747fp)

    No theres no such files/folders and plus its theme-independent whatever is causing the problem. i just switched the active theme to Twenty Twelve and it still wont add to cart. it wont work for Simple products either.

    it must have something to do with cookies.
    i viewed the site after clearing cookies and in the cookie viewer, it shows these

    woocommerce_recently_viewed
    wc_session_cookie_7f8d6c2bea19fa7c2492f6f44bddef0c

    That is all it lists

    b747fp

    (@b747fp)

    comparing against a fresh install of WP and WC, the “woocommerce_cart_hash” cookie is missing from my live site?

    b747fp

    (@b747fp)

    it has something to do with permalinks. if i turn Default permalinks on it works. weird

    simmonsstummer

    (@simmonsstummer)

    i have the same problem.
    I use wootique as theme and it does’t override pages.
    My product simply doesn’t go to the cart.

    tamaron

    (@tamaron)

    Same here! but it doesn’t work changing to default permalinks neither.
    Using the code of the add to cart button only shows a grey box with the price inside, but no button…

    simmonsstummer

    (@simmonsstummer)

    I’ve half resolved.
    Some of my problems depends from the gravity form addon. I upgraded it and now i’m partially able to add to cart. There is still something wrong with the new version (2) of woocommerce.

    pansyflower

    (@pansyflower)

    I have problems with delivery choice, it’s impossible to make it vis radio buttons, screwed up the product page and lots or other things….

    pansyflower

    (@pansyflower)

    ok, I’ve found the solution of adding to cart abd variation choices – I’ve disabled the Reviews and everything is okay now

    miocene22

    (@miocene22)

    I am having the same problem – using a custom theme but no template overrides. Only a few plugins (easing slider and akismet). When I try to add an item to cart the page refreshes but the cart is not updated.

    The only caching I have is opcode apc which is configured on the server.

    did anyone solve this?

    Hey guys, did you find a way for those using Wootique

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Add To Cart not working after upgrade’ is closed to new replies.