WordPress.org

Support

Support » Plugins and Hacks » Add to cart not showing for variable product

Add to cart not showing for variable product

Viewing 15 replies - 1 through 15 (of 21 total)
  • I’m pretty sure something wrong with the javascript inside plugins/woocommerce/assets/js

    may be replacing it will fix.

    i had this when trying WC 2.0 beta

    no workaround released yet?

    I too am having this problem, would love some help.

    This could be due to having your variations setup incorrectly in the admin.

    or this could be a theme issue, try reverting to a standard theme like twenty eleven or twenty twelve and see if the problem still persists.

    Thanks

    What should I check for in the admin? It works when I switched to Twenty Eleven

    thanks for the reply

    would this be a conflicting code? im not understanding why the single item works, but the variable one doesnt. what code is different for the cart?

    i posted about this issue and have seen several people post about this apart from my own thread. i was having the same issue if and only if i used the js minify option in with the w3 total cache plugin.

    problem is, my site loads soooooo slowly (sometimes 30 seconds) i really have to figure out how to optimize it without the plugin anyway.

    seems like this is a known-bug… where can we find an answer? how can we get this thread to more experts?

    This is a theme issue, if it works when switched to the Twenty Eleven theme, your theme is overriding the JS for the add-to-cart-variable file.

    This could be that the jquery version is old, it could be that some other piece of code is conflicting.

    Thanks for the reply, guess I will contact the theme designer. For reference, it’s this theme:

    http://wp.io/wordpress-theme/theme1562/

    Oddly, Template_Help.com doesn’t work (the theme creator)

    In my case that isnt the issue. I disabled all other java files that were running other then the ones running from the cart file. Still had a conflict. I wish there was some documentation to tell why the simple and variable product are pulling the cart in separate ways. It should just be passing a variable to the same form.

    I’ve been having the same issue with various woothemes plugins I’ve purchased. I’m running the Mercor theme, using Gravity Forms Add-ons and Swatches and Color Picker and neither of them work with my theme.

    I’m being bounced back and forth between woothemes and the Mercor theme developers. It’s a nightmare.

    I hope someone can shed some light on this.

    Here’s an example: http://www.verezsuits.com/shop/suit/charcoal-suit/

    Here’s the fix for my theme … until it gets fixed in the plugin itself …

    Add this to your functions script:

    function fix_woo_var_cart()
    {
      wp_enqueue_script('add-to-cart-variation', '/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart-variation.js',array('jquery'),'1.0',true);
    }
    add_action('wp_enqueue_scripts','fix_woo_var_cart');

    That’s my crude code taken from another forum thread but it works fine.

    I also try this but not working for me. Any other solution?

    Hi there, fairly new to this. Where exactly in the “Functions.php” file of the theme do you paste the code. I am not sure if you can insert it anywhere or if there ios a specific place. Kind regards

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Add to cart not showing for variable product’ is closed to new replies.