Support » Plugin: MarketPress - WordPress eCommerce » Add to Cart does not work

  • Resolved MrMyles


    Just downloaded and installed MarketPress Lit 2.9.2 using it on a fresh WordPress install (3.8.1) with no other plugins activated.

    When I add a product to the cart, it gets added to the cart in the sidebar widget.

    If I add a second product, the first is removed from the cart.

    If I click on Checkout, the product is removed.

    Same thing happens if I am on the main products page, or an individual product page. No matter how I do it, anytime I use Add to Cart, nothing actually gets added.

    If I remove the “Add to Cart” option and just use “Buy Now” everything works fine.

    If I use IE Add to Cart does nothing but spin.

    I have tested all MarketPress settings, turning things on and off. I have deactivated, reactivated, uninstalled and reinstalled.

    What am I missing?

    See video here:

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have also tried using default templates in addition to my custom template. Same result.



    WPMU DEV Support Staff

    Hi @mrmyles,

    I hope you’re doing well today! 🙂

    Sorry you’re having trouble with that. Could I ask if you tried using a default theme, perhaps Twenty Fourteen theme?

    If not, could you try it using that theme and let us know how it works?

    Just to check also, could you let us know how much memory available on your server/site?


    Yes, as per my last post I tried different themes.

    How much memory? In terms of what?



    WPMU DEV Support Staff

    Hi @mrmyles,

    Thanks for your reply and sorry if I misunderstood. I thought by “templates” you were referring to the theme options included in MarketPress itself.

    Also, sorry if I was unclear about the memory. I was referring to your server’s available memory.

    You could normally get that by creating a blank .php file in your root folder then including the following in it, and going that file in your browser:
    <?php phpinfo(); ?>

    Or more easily, you could use this:

    The memory_limit item displayed with that should yield your available memory. Could you let me know what that shows?

    Also, would it be possible for you to try deactivating other plugins and testing with that?

    Just wondering if that might be due to a plugin conflict.

    I’ve been testing the cart and checkout in a local test site and haven’t been able to replicate the issues so I’m just trying to find what’s different on your site that’s causing that.

    If you have questions an anything please feel free to ask. I’ll be happy to help. 🙂


    David, Thanks for trying to help. I appreciate it.

    Server memory is 256MB
    As for plugins, reread my original post.

    This is the second time I installed the free version on a site and had nothing but trouble. For my other site I bought the paid version and it works. Happy with it. This site, I won’t buy the upgraded version. Need just the very basics. Can’t see myself continuing on with this free plugin, given I have never been able to get it to work.

    Last time, shipping did not work, no matter how it was set. Never got an answer why. Now Add to Cart does not work. Different sites. Different servers. Different free plugin versions. Same result, not working. I will give it another shot, then delete and use something else.



    WPMU DEV Support Staff

    Hi @mrmyles,

    Thanks for your replay. Really sorry you’re having that trouble with this one. I’d love to get it sorted though.

    Could you let me know what you have for the shipping settings, perhaps provide a screenshot?

    For that matter, could you provide a screenshot of the main settings page as well?

    That’ll help me to replicate the issue. And if I can replicate it I can get a solution.

    Also, I’m not sure if you realize but you can use the paid version in this site as well. The license is the same as regular WordPress plugins, you can use it in all your sites.

    I’d really love to get these issues sorted though. If you could let me know the above, that’ll definitely help.

    Meanwhile, I’ll try some different settings and see if I can replicate it with that.


    This sites does not have issues with shipping. Other site did. Well, maybe this one does, no clue. Since I cannot add to cart I cannot place an order and test shipping.

    I had no clue I could use the paid version on multiple sites. I will grab the plugin from my other site and test that. Thanks.



    WPMU DEV Support Staff

    Hi @mrmyles,

    Thanks again for your reply. I was actually asking about the shipping in case the cart issue might possibly be related to the shipping options you’ve set. Similarly, it could be related to the other options.

    If you’d like to continue working through that, I’d love to help. Just let me know. 🙂


    I have gone through all store options, payment, shipping etc.
    Unless there is some hidden setting that tells it not to work unless I turn it off, then it does not worl/.

    Even installed the full version from my other site. Same thing, nothing ever gets added to cart.

    Custom Theme w/plugins: Does not work
    Custom Theme w/o plugins: Does not work
    Default Theme w/plugins: Does not work
    Default Theme w/o plugins: Does not work
    Free version: Does not work
    Paid version: Does not work

    I like the plugin, works well on my other site. This site, it fails 100% of the time and I cannot keep debugging. Faster just to find a different cart system.

    Hi @mrmyles,

    Could you please share us your site link where you are having problem with MarketPress plugin so that we can troubleshoot it?


    Plugin Author WPMU DEV – Your WordPress Toolkit


    WPMU DEV Support Staff

    Hey there.

    Great to see it works well on your other site.

    Sorry to see we couldn’t get this one sorted thought. 🙁

    If you already have the full version then I guess you might have an active membership. If that’s the case then our staff would be more than happy to log in and debug that for you.

    WP rules state that we can’t support commercial products here so you would need to contact us directly regarding the full version.

    Do let us know if we can help further.

    Have a great day!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Add to Cart does not work’ is closed to new replies.