Support » Plugin: Product Variation Table for WooCommerce - PVT » Add To Cart button no longer working on mobile devices/screens

  • Resolved motorcityseeds

    (@motorcityseeds)


    Hi – my PVT variation table was working beautifully (on Product page) using slightly older versions of Elementor Free + Pro. Until I just updated Elementor Free + Pro and OceanWP theme to current versions. Now the variation table Add To Cart button no longer works/responds on mobile devices, issue only happens on mobile (iphone), on a Desktop screen, AddToCart is still working fine:
    On a mobile device screen, when user clicks on Add To Cart button, button changes to Hover state/color but then nothing else happens, i.e. on a mobile device clicking Add To Cart has no effect so user can’t add product to cart.
    (If I deactivate PVT table and add the plain/regular Add To Cart widget, that AddToCart button works fine on mobile. Every other button on Product page still works fine on mobile, problem only occurs with PVT table)

    Hoping this can be fixed as plugin was working beautifully before, but if user can’t Add To Cart on mobile then that’s a showstopper 🙁

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Hakik Zaman

    (@hakik)

    Hi @motorcityseeds

    Thanks for reaching out to me. I am very sorry for your inconvenience.

    Are you using Elementor Theme Builder to display product page?

    If it works with desktop version it should work with mobile version too. Could you please provide me a direct link to your product page?

    Please also let me know is it happens with only iPhone or any small screen. I have already tested it with latest OceanWP theme and Elementor (Free), but couldn’t reproduce the issue.

    Hope to hear from you soon.

    Thanks

    Thread Starter motorcityseeds

    (@motorcityseeds)

    Hi,

    I appreciate the quick & thoughtful follow-up:

    Yes, our Product page was created using Elementor Pro’s Theme Builder (Product page is opened/edited via a Template in WordPress’s Templates menu) (PVT table was added to Product page via shortcode. Was looking & working great until the recent system update.)

    (also FYI – in case this info is helpful in isolating the issue: I recently installed the latest PVT Table update where I noticed the new feature to set minimum table width. Only noticed that new feature because after the update, the default setting on new minimum width feature pushed my AddToCart buttons off the right edge of desktop screen, after I adjusted the minimum width (changed it to 0) the PVT table layout is showing up nice again. However now that I think about it, am not sure we tried clicking AddToCart on mobile after the recent PVTtable update. So I am wondering if issue started happening after the PVT table update, or did it only start happening after Elementor & OceanWP updates? (I updated Elementor Free + Pro and OceanWP theme 2 days after installing latest update to PVT table. We only noticed AddToCart issue after updating Elementor/OceanWP but we recently installed latest PVT update a couple days before and didn’t test AddToCart button-click on mobile so there’s a possibility AddToCart button issue was happening since PVT table update and we just didn’t see it until we happened to update Elementor/theme?)

    We just tested and AddToCart issue is happening on Android phones/screens too (and on newer-model iPhone + older-model iPhone).

    Am happy to give you link to our Product page where the issue’s occurring — however we’re currently on a private server (our shop/app isn’t live yet), would rather not post link in public forum until we’re sure everything’s working Just Exactly Perfect :-). Please let me know a good way to get you login details for our dev site (and/or can email contact info to team@motorcityseeds.org 🙂

    Thank you

    Plugin Author Hakik Zaman

    (@hakik)

    Hi @motorcityseeds

    Could you please check your email?
    I have been waiting for your response because your site is in under construction.

    Thanks

    Thread Starter motorcityseeds

    (@motorcityseeds)

    Successfully & promptly resolved/fixed! Appreciate the great support! 🙂

    Plugin Author Hakik Zaman

    (@hakik)

    Hi @motorcityseeds

    Thanks for your appreciation. Your patience level was remarkable.

    Your issue fixed with this Version 1.3.13 (Latest release)

    Have a great day 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.