Support » Plugin: WooCommerce » Add to cart after update to 3.6.0

  • Resolved WEBDEPOTET

    (@webdepotet)


    After updating to 3.6.0 – i got 2 problems.
    When i log out of woocommerce, i get 404 window from CloudFlare

    And second problem, when i add a product to cart – the cart is empty (first product)
    If i add again, it goes well..

Viewing 15 replies - 1 through 15 (of 29 total)
  • News: I roll back to 3.5.8 – fixed the 2 problems..

    Plugin Support Shane Eckert

    (@shaneeckert)

    Automattic Happiness Engineer

    Hi,

    Does the issue persist with adding to the cart? Or was this a one time thing after the update?

    If it’s still happening, can you disable CloudFlare and see if adding items to the cart work as expected?

    Thank you.

    After updating to 3.6 – the 2 issues appeard and got very slow site

    Roll back to 3.5.8 – worked again
    I cannot disable cloudflare, they run SSL

    Some issue in add to cart in woocommerce 3.6

    Like, you had to add to cart one time, and it opened cart after – and showed “Empty cart” – go back – reload the page – add one more time, and it works

    Plugin Support Shane Eckert

    (@shaneeckert)

    Automattic Happiness Engineer

    I am not able to replicate on a fresh install of WooCommerce 3.6.0. I can add an item to the cart as a logged out user with no issues at all.

    The next step is to test without CloudFlare in place. Can you duplicate your site so that you can do some testing without effecting your customers?

    WP Staging is great for this.

    Same thing here. Catastrophic update 3.6…
    Also: thumbnail image sizes have been reset, variations with image change on click on color/size is not working, etc.
    Seriously…

    I also notice alot of misbehavior under category pages, where subcategories are displayed

    I am not able to do stable testing sorry, to big live site

    Anyhow i can share url without google loading it here?

    Same issue with add to cart here.
    The cart stays empty for the first add to cart action on a fresh session (new browser, no cache). When adding the product again to the cart, it works.

    (no Cloudflare in between)

    Yes, correct explained, same here

    I have to delete cookies to get the issue back

    Plugin Support Shane Eckert

    (@shaneeckert)

    Automattic Happiness Engineer

    Are you using Ajax add to cart?

    i’ve tried to deactivate that, to see if anything happent, and that had no effect

    LNN

    (@ewan-norman)

    No problem with adding to cart so far, only big thumbnails in product pages, but this is due to my theme (oceanwp), needs to update the product pages template.
    Apart from this everything is working fine, I even noticed a slight increase in performance.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Add to cart after update to 3.6.0’ is closed to new replies.