Support » Plugin: WooCommerce Blocks » Add to Basket / View Basket

  • Resolved David Bennett

    (@bennettskaya)


    On a product page when I click to ‘Add to Basket’ then I see a signifier to show that it has been added to basket. I know that the precise signifier is partly theme dependent.

    On a page where I use the Hand Picked Products block, when I click to Add to Basket, what I then see is the words ‘View Basket’ that appear next to the ‘Add to Basket’ button. See screen grab on Droplr here: https://d.pr/i/97QiDH

    Is that normal behaviour and if so, how can I change it to behave in the same way that ‘normal’ product buttons behave.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Dani F. a11n

    (@danielinhou)

    Hi @bennettskaya👋🏽,

    This is what I see using the Storefront default theme when I click on the add to cart button using either the Hand-picked Products block or any other block/shortcode:

    Adding to cart
    Link to image: https://d.pr/i/rfKlCp

    Could you please clarify how the other buttons are behaving?

    Cheers!

    Thread Starter David Bennett

    (@bennettskaya)

    HiDani,

    Thank you for the video. This is how the ‘Add to Cart’ works with products on the product pages on my site. I am using the GeneratePress theme.

    The video is on Droplr and it should open in a new tab.

    https://d.pr/v/mrff9R

    Kind regards,

    David

    Plugin Support Joey – a11n

    (@jricketts4)

    That styling is indeed handled by your theme. I would suggest reaching out to them to see if they can target that specific text class to style it like the other buttons as well.

    Thread Starter David Bennett

    (@bennettskaya)

    Thank you. In fact I prefer the behaviour that the theme dictates because our customers tend to buy several products in one order, so we prefer not to direct them to view the cart.

    The important thing for me is that I now understand the behaviour of the Products block.

    Has it always behaved that way through its iterations?

    Plugin Support Dani F. a11n

    (@danielinhou)

    Hi @bennettskaya 👋🏽,

    Glad to see that we’ve solved your doubt. I am not entirely sure if this has been original behaviour since the very first interactions but I have tried this now with quite a few older versions and I see the same results.

    I’ll mark this thread as resolved now. If you have any further questions, I recommend creating a new thread.

    Cheers!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.