Support » Plugin: AddToAny Share Buttons » Add-To-Any buttons all redirect to!

  • Resolved q292u


    If I click on the add-to-any button, then select digg, or delicious, all that happens is that I get redirected to the add to any homepage!

    It used to work, and I really don’t want to change to another plugin.


    Try it yourself:
    Click on one of the posts (the share buttons dop not appear on the homepage, and try and submit something to digg or delicious..

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author micropat


    It’s working on all other sites. If you re-enable the plugin we can take a look.

    It’s re-enabled. Still misbehaving..

    Plugin Author micropat


    So it’s not merely linking to, it’s falling back to AddToAny’s sharing page on, which is normal if the drop-down menu isn’t being called.

    The problem with your missing drop-down menu seems to be that the button is invisibly outputted prematurely. This is often caused by misbehaving ‘related posts’ or ‘featured post’ mechanisms. Did you enable that Contextual Related Posts plugin recently? That very likely could be the problem.

    Got the same error since I made a complete redo of a site. Before Efficient Related Posts plugin and AddToAny lived in perfect harmony and I’not sure if they aren’t still. The drop down menu does not come back if I deactivate the related posts.

    I have the same problem and only updated TubePress since the last time I used AddToAny to tweet. I deactivated TubePress, but the problem with AddToAny remained. I tried clearing my browser cache and using a different browser. Neither helped. I’m deactivating AddToAny pending resolution. If there’s anything you want me to try, Pat, say the word. You have my email address.

    Plugin Author micropat


    Thanks for the reports guys!

    There was indeed a bug in yesterday’s major AddToAny release that temporarily caused the drop-down menu to not appear properly on the latest version of the WordPress plugin. Fortunately, this was an easy fix and the fix landed a few hours ago.

    Simply reload one of your pages with AddToAny on it and you should see the menu working normally again. Thanks again for the reports!

    I have the same problem on my site.
    Have no idea what causes it, and tried reloading after the last post here, but doesnt work, even looked at OP post and its still the same on his site.

    Please have a look on my site and see if you notice any plugin that can interfere or something.

    Version .9.9.7 is working again. Three Cheers!

    Plugin Author micropat


    @afranzon you don’t have AddToAny enabled right now so it’s hard to tell. The OP’s issue is caused by the Contextual Related Posts plugin. Not sure if you have the same issue until you re-enable, but your Popular Posts and/or Recent Posts features are suspect.

    Ok, i re-enabled the addtoany plugin now! Please take a look.

    Plugin Author micropat


    @afranzon your issue is totally different. 🙂 It looks like you are using the script caching feature. Uncheck “Cache AddToAny locally with daily cache updates **”, save changes, and try that.

    With script caching enabled, for some reason in your source code it’s showing two slashes: “” which is an interesting issue. Would love to troubleshoot that with you later.

    Thank you for the answer!
    It worked when i unchecked the cache button, dunno why it was checked! 🙂
    About the two slashes, its been since i started the site, dont know if its the theme or what, its the same when uploading pictures and everything. Altho it do work, but looks weird! 🙂

    Nope. Still redirecting to the share page.
    I’ve installed the latest release of add-to-any, and it still doesn’t work..

    I have “add to any” working in harmony with contextual related posts on another site :

    But not on this one:

    It’s acting up again for me. It was working fine a few hours ago. I deactivated it because it was causing a long delay in page loading. Everything would load to right below the icon and then take a long time to load the rest of the page. Clicking on the icon opened the addtoany site with small icons covering the linked text. I had had it opening just the menu. I’ve changed absolutely nothing on my end since it was working. Thanks.

    Moderator James Huff


    Volunteer Moderator 🚀

    Tom, the Add to Any crew were moving some of their resources to a new CDN around that time, so I imagine things were bit unstable.

    Everything appears to be loading relatively snappy now, perhaps even quicker than before.

    If you notice any lingering performance issues, I’m sure they’ll be ironed out over the next few hours.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Add-To-Any buttons all redirect to!’ is closed to new replies.