WordPress.org

Support

Support » Plugins and Hacks » [Resolved] add thumbnail option is not showing

[Resolved] add thumbnail option is not showing

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Michael Beckwith

    @tw2113

    click the “Advanced options” link and verify that you have “Featured image” checked towards the bottom of the page. If it is, and you’re still not seeing anything about it, make sure that your custom post type screen editor is showing the metabox for it. You can confirm that in the “Screen options” tab at the top. It should be along the right when checked.

    Thanks for the reply Michael. Is it possible, can i chat with you regarding this issue ? I would be glad if you give me your gmail id.

    or may be add me : kuldeep.singh@learnnovators.com.

    Thanks

    Plugin Author Michael Beckwith

    @tw2113

    I’d prefer it stay here on the forum. You never know when someone else may have the same issue. If we kept everything private, they’d miss out on the solution.

    Everything is marked Michael, but still the option for thumbnail is not showing up.

    Custom code for that page is :

    add_action('init', 'cptui_register_my_cpt_courses');
    function cptui_register_my_cpt_courses() {
    register_post_type('courses', array(
    'label' => 'courses',
    'description' => '',
    'public' => true,
    'show_ui' => true,
    'show_in_menu' => true,
    'capability_type' => 'post',
    'map_meta_cap' => true,
    'hierarchical' => false,
    'rewrite' => array('slug' => 'courses', 'with_front' => true),
    'query_var' => true,
    'supports' => array('title','editor','excerpt','trackbacks','custom-fields','comments','revisions','thumbnail','author','page-attributes','post-formats'),
    'labels' => array (
      'name' => 'courses',
      'singular_name' => 'courses',
      'menu_name' => 'courses',
      'add_new' => 'Add courses',
      'add_new_item' => 'Add New courses',
      'edit' => 'Edit',
      'edit_item' => 'Edit courses',
      'new_item' => 'New courses',
      'view' => 'View courses',
      'view_item' => 'View courses',
      'search_items' => 'Search courses',
      'not_found' => 'No courses Found',
      'not_found_in_trash' => 'No courses Found in Trash',
      'parent' => 'Parent courses',
    )
    ) ); }

    do you find any issue ?

    Plugin Author Michael Beckwith

    @tw2113

    Nope, that part checks out, which leads me back to the idea that the metabox simply isn’t being displayed on screen, or maybe you’re not quite recognizing in.

    try adding smthn like this in your functions.php

    add_action( 'after_setup_theme', 'enable_thumbs' );
    function enable_thumbs() {
    add_theme_support( 'post-thumbnails', array( 'post', 'custom_post_type', 'another_custom_post_type', 'one_more_cpt' ) );
    }
    Plugin Author Michael Beckwith

    @tw2113

    what eria86 said should cover the rest of the case. Otherwise if you’re able to set the images and whatnot, but it’s not showing up on the frontend, you’ll need to edit your theme to use a function like the_post_thumbnail, http://codex.wordpress.org/Function_Reference/the_post_thumbnail, or so to actually display them

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] add thumbnail option is not showing’ is closed to new replies.