Support » Plugin: Auto Upload Images » Add support for HTTPS base URL

  • Resolved Ducktales

    (@ducktales)


    When your WordPress blog is working with HTTPS the plugin still uses HTTP urls, causing errors in the browser and of course undermining the security and HTTP/2 optimization.

    The fix is simple. In wp-auto-upload.php change:

    $base_url = $uploader->getHostUrl() == null ? null : "http://{$uploader->getHostUrl()}";

    To:

    $base_url = $uploader->getHostUrl() == null ? null : "//{$uploader->getHostUrl()}";

    https://wordpress.org/plugins/auto-upload-images/

Viewing 2 replies - 1 through 2 (of 2 total)
  • It would be better to include the protocol directly from the base url setting. Actually, I don’t understand why you are altering the value of that setting in ImageUploader.php getHostUrl(). It should be used as provided.

    ImageUploader.php – getHostUrl()

    return $url ?: WpAutoUpload::getOption('base_url');

    wp-auto-upload.php – save()

    $base_url = $uploader->getHostUrl() ?: null;

    Plugin Author Ali Irani

    (@airani)

    Thank you, fixed at the next version (after v3.0.1) and released coming soon

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Add support for HTTPS base URL’ is closed to new replies.