Support » Plugin: WP RSS Aggregator » "Add New" shows items, then "No Imported Feeds Found"

  • Resolved ivilata


    Hi! I’ve been experiencing what seems exactly the same issue previously reported here: (no published solution there, unfortunately).

    That is, I can add new feed sources (a bunch of them, which work with other tools) to the Aggregator, and their items show up under “Feed Preview” in their corresponding feed source page. However, going to “Imported Feeds” shows “No Imported Feeds Found”, and using [wp_rss_aggregator] in a page shows “No feed items found.”. Curiously, the “Next Update” column under “All Feed Sources” shows increasing time spans. “Delete and Re-import all feeds” as stated in the FAQ didn’t help either.

    I’m using plugin version 3.9.9. I already looked at other similar issues but found no solution in them, the one linked above is the one most similar to my problem.

    Thanks for your help!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Miguel Muscat


    Hi ivilata,

    Can you please send us the feed sources, or some of them, you are using ?
    We will try to debug the problem using the same feed sources and get back to you.

    Of course, here they are:

    I also tried pausing the 2nd and last one (which give some warning in W3C’s RSS Validator, although they work with other applications) and deleteing and reimporting then, but I still get “No Imported Feeds Found”.

    BTW, the affected site is

    Thank you!


    I have checked the first feed and it turns out the latest version (not yet released) handles it fine. I may also try it in the latest stable release if you still have problems.

    Do you get anything in the feed preview in the Edit Feed Source page?

    Please, excuse us for the delay. You will be receiving replies for queries this plugin in a timely manner from now on.

    Thanks Daniel. Yes, I get the latest entries for each feed in their respective feed previews, hovever “Imported Feeds” still shows “No Imported Feeds Found”.

    I noted that the “” feed shows “Invalid feed URL” but I know that may be a problem with certificates. I paused it and fired “Update All Feeds Now” but still no entries are shown under “Imported Feeds”.

    Thank you!

    And you’ve created a page for all feeds? I am having the same issue with but have asked the rest of the team behind the plugin about this. Will keep you informed.

    The main page in contains a block with [wp_rss_aggregator] on the left. Running wget -O /dev/null in the same host gives no problems at all (and Wget is quite picky about certificates). Thanks!

    Plugin Author Miguel Muscat


    Hi iviliata,

    I have tested the feed sources with the latest version (v4.0.7), and they all worked.
    Initially, the first feed source didn’t fetch, and the others did. I went to the Debugging page, noticed an error in the error log, and tried the “Update all feeds” operation and it imported just fine.

    I set up a simple page with the [wp_rss_aggregator] shortcode, and all feed items were shown.

    A few of questions regarding your setup:
    – What version of the plugin are you running ?
    – Are you running any of the premium add-ons ?
    – Do you have any limit options set in the settings ?
    – Can you see the number of feed items imported under the “Imported items” column in the feed sources page ?
    – Can you see the feed items in the “Imported Feeds” page ?

    I nearly put head through a wall with this same problem tonight. I think I found a solution…check your feed URL in the feed editor there might be a space at the end of the URL. It will validate and show a preview even if there is an extra space, but if you leave the extra space it won’t import. Good luck!

    Plugin Author Jean Galea


    @nynapper Thanks for suggestion, if that turns out to be the case I think we can automatically trim any white space when saving the feed source, thus eliminating the possibility of this mistake. Let us know how it goes @ivilalta.

    nynapper, Jean, I checked that no feed URL had leading or trailing characters (spaces or other), so this doesn’t look like the cause in our case.

    Regarding Mekku’s questions:

    > – What version of the plugin are you running ?


    > – Are you running any of the premium add-ons ?

    No, we aren’t.

    > – Do you have any limit options set in the settings ?

    Sorry, could you point me to where I can get the value of these options? Thanks!

    > – Can you see the number of feed items imported under the “Imported items” column in the feed sources page ?

    Yes, it remains 0 for each one feed.

    > – Can you see the feed items in the “Imported Feeds” page ?

    I can see a “No Imported Feeds Found” line in there, which is consistent with the previous counts but obviously not what we’d want to see. 😉

    Thanks again for your help!

    Plugin Author Jean Galea


    I think the best thing is for us to take a look at your site and see what’s happening as it looks like an isolated case and not something we’ve come across before. Can you send us a login to

    I need to get permission for this and then I’ll come back to the thread. In the meantime, what are the limit options I should check? Thanks!

    I am having the same issue as ivilata.

    I’ve got two feeds:

    Both feeds are valid per the validator. The first one seems to import just fine; it shows the last 5 feed items available and indicates that there are 15 imported items. The shortcode brings up the feed. The second one, however, indicates 0 imported items and when using the shortcode indicates “No feed items found”, yet contains a feed preview displaying the last 5 feed items. Defaults down the board for both feeds.

    There is nothing in the error log. System information follows:

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: Yes


    Plugin Version: 4.0.7
    WordPress Version: 3.7.1

    Platform: Linux
    Browser Name: Chrome
    Browser Version: 32.0.1700.107
    User Agent String: Mozilla/5.0 (X11; Linux x86_64)
    AppleWebKit/537.36 (KHTML, like
    Gecko) Ubuntu Chromium/32.0.1700
    .107 Chrome/32.0.1700.107 Safari

    PHP Version: 5.3.28
    MySQL Version: 5.1.72-ius-log
    Web Server Info: Apache

    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Post Max Size: 20M
    PHP Time Limit: 30000

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 6 Status: Acceptable

    Show On Front: page
    Page On Front: Home #16
    Page For Posts: Home #16

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /var/lib/php/session
    Use Cookies: On
    Use Only Cookies: On

    WordPress Memory Limit: 96MB
    FSOCKOPEN: Your server supports fsockopen.


    Advanced Custom Fields: 4.3.4
    All In One SEO Pack: 2.1
    Black Studio TinyMCE Widget: 1.2.0
    Categories Images: 2.4.1
    Column Shortcodes: 0.6.4
    Custom Editor Styles: 1.0
    EDF Social: 1
    Feedburner Email Subscription Widget: 2.0
    Promo Widget: 1
    Recent Posts with images: 1
    Sidebar Promo: 1
    Simple Page Sidebars: 1.1.5
    WordPress Importer: 0.6.1
    WP RSS Aggregator: 4.0.7
    Yop Poll Plugin: 4.9


    WPide: 2.3.2


    edf: 1.0

    ### End System Info ###

    Plugin Author Jean Galea


    @braican I just tried it on my setup and it worked fine, any chance we can get access to test things out on your end? If so please email on

    Sorry for answering so late but I’m unable to give you access to the machine, and in the end we migrated to planet-stlye aggregation. I guess the thread is valuable though since some other users came up with the same problem. 🙂

    Thanks a lot anyway for your time and congrats for your work!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘"Add New" shows items, then "No Imported Feeds Found"’ is closed to new replies.