WordPress.org

Forums

Role Scoper
'Add New' links and buttons for posts and pages have dissappeared since upgradin (6 posts)

  1. disphoria
    Member
    Posted 2 years ago #

    Since I upgraded RoleScoper and WordPress all the 'add new' links and buttons for posts and pages have dissappeared.
    deactivating the Role Scoper plugin makes the 'add new' buttons reappear, but as soon as i reacitvate the plugin they dissappear once again.
    I've been through the forums looking for an answer but can't see th exact problem i'm experiencing here.
    I tried downloading the development version but this had the same effect.
    I also tried using a previous version but this caused an error message and couldn't be installed.
    I've tried switching off all the plugins and Role Scoper appears to be the culprit.
    Please help since I'm using it for a busy community radio station website and it's needed to allow the presenters to keep their pages updated.
    thanks

    http://wordpress.org/extend/plugins/role-scoper/

  2. disphoria
    Member
    Posted 2 years ago #

    to make it clearer: the 'add new' buttons are dissappearing when logged in as admin so admins can't add new pages or posts

  3. courtneycj
    Member
    Posted 1 year ago #

    I'm having the same problem with my university department's website. Did you find a fix, disphoria?

  4. disphoria
    Member
    Posted 1 year ago #

    I'm sorry to say that I gave up after spending houurs searching forums for a fix. i just had to remove rolescoper altogether since it was breaking the site.
    which is a shame since it was really useful to be able to offer the presenters the chance to update their own pages.
    I might have to rebuild the site and since WordPress and Rolescoper will have been updated several times since this occurred i hope it will work this time.
    I wish there was a less enormous alternative to Rolescoper since I only wanted one commonly needed function - to restrict each user to editing their own page.

  5. Kevin Behrens
    Member
    Plugin Author

    Posted 1 year ago #

    Take a look at Roles > Options > Features > Content Maintenance > "Require create_posts capability"

    If you have enabled that, you need to also use a WordPress role editor such as Capability Manager Enhanced to add the create_posts, create_pages, etc. roles to desired roles.

  6. lukeoatham
    Member
    Posted 1 year ago #

    Thank you. I was having the same problem. This fixed it for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Role Scoper
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic