WordPress.org

Support

Support » Plugins and Hacks » Pretty Link Lite » [Resolved] Add New Link gives Warning: opendir Access Denied to .\PrliUtils.php and readdir

[Resolved] Add New Link gives Warning: opendir Access Denied to .\PrliUtils.php and readdir

  • I have a fresh install of WordPress at GoDaddy with Windows hosting. I have 5 other sites on Windows and one with 7 subdomains and never any issues until today. Immediately after fresh install I changed the url to begin with ‘www’, changed the admin email, then installed Smpl Skeleton theme, next installed Pretty Link Lite then Limit Login Attempts. Then I went to ‘Pretty Link’->’Add New Link’ and received the following warnings:

    Warning: opendir(D:\hosting\…\html/,D:\Hosting\…\html/)[function.opendir]:Access is denied. (code: 5) in D:\Hosting\…\wp-content\plugins\pretty-link\classes\models\PrliUtils.php on line 112

    Warning: opendir(D:\Hosting\…\html/) [function.opendir]: failed to open dir: Bad file descriptor in D:\Hosting\…\html\wp-content\plugins\pretty-link\classes\models\PrliUtils.php on line 112

    This one repeats maybe several hundred times.

    Warning: readdir() expects parameter 1 to be resource, boolean given in D:\Hosting\…\html\wp-content\plugins\pretty-link\classes\models\PrliUtils.php on line 114

    Any thoughts to what a solution might be?
    Thanks in advance,
    Jeff

    https://wordpress.org/plugins/pretty-link/

Viewing 4 replies - 1 through 4 (of 4 total)
  • I just noticed the message on the Pretty Link page the site must have the permalinks configured or it will not work correctly. I changed that in ‘Settings’->’Permalinks’ too ‘Post name’ and still no luck.

    Sorry, no prevail. I changed my hosting package to Linux from Windows. As we all know that is the preferred method to begin with but I was trying to accommodate other business needs.

    Thanks!

    Plugin Author cartpauj

    @cartpauj

    Yeah, Windows typically uses IIS web server which is not compatible with WordPress’ .htaccess rewrite rules. Apache is a much better base for WordPress than IIS.

    Thanks Cartpauj. What’s strange is it works great on other Windows hosted sites I have. Something I did find but haven’t completely proven is, for example, if http://MyDomain.com is inaccessible and http://www.MyDomain.com is and is also the configured base url in WordPress some plugins do not work properly which might include Pretty Link Lite. In my case, MyDomain.com points to my Active Directory domain and http://www.MyDomain.com points to the website. This setup, by the way, is very problematic and not necessarily related to any plugin or WordPress framework but potentially the overall network design.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Add New Link gives Warning: opendir Access Denied to .\PrliUtils.php and readdir’ is closed to new replies.
Skip to toolbar