Support » Requests and Feedback » Add New Category doesn’t work

  • The + Add New Category link hasn’t worked since upgrading to 2.8. Clicking on the link does nothing.

    I’m using Safari 4 with Gears enabled, although none of my other browsers act differently in this regard.

    Also, when the browser loads the dashboard page after login, Safari gives the following error message:

    TypeError: Result of expression near ‘…n’.split(‘|’),0,{}))…’ [undefined] is not a function.

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi


    Forum Moderator

    Try deactivating/deleting Google Gears. It can cause problems in WordPress.

    Also try deactivating all plugins and check to see if this resolves the problem. If it does, activate the plugins one by one – checking the site after each re-activation – until you find the problematic plugin(s).

    Thanks for the feedback. I hadn’t considered disabling Gears. Today’s a new day, though — here’s what happened:

    I walked away from by blog for a day or so, then got back into it today. When I went to the dashboard, suddenly the newsie items at the bottom that had been giving me some kind of “fetching data” error, suddenly had content. OK.

    So I went into a post and tried to add a category. The new category box popped open! When I typed in a new category and hit save, I got the error message:

    Warning: Cannot modify header information – headers already sent by (output started at /Users/gregraven/quotes/wp-config.php:153) in /Users/gregraven/quotes/wp-includes/classes.php on line 1586

    So I went to wp-config.php and checked line 153. This line and the line above it were blank, so I deleted them. With no other changes, my blog started working right.

    So I checked the pages to see that the formating and content were OK. The new version had added a couple of things back I didn’t want, so I tried to edit them out in the built-in editor. No save button. Hmmm. Well, I used Fetch and BBEdit and made the fixes.

    Bottom line, there are still some bugs lurking about — perhaps in Gears — but at least my blog is working again.

    Thanks again for your help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Add New Category doesn’t work’ is closed to new replies.