• Resolved Kushal Azza


    Hi team, thanks for the amazing plugin.

    I just noticed that the “Add missing TITLE attributes” setting is automatically adding the title tag on images even though the title is mentioned on a media file.

    Steps to reproduce:
    1. Enable “Add missing TITLE attributes” in General Settings
    2. Create a post and upload a few images.
    3. Enter the title, description, caption, and alt text for the images.
    4. Publish the post and notice the image title tag.

    Though we have entered the title tag, the RankMath is ignoring the tag and inserting an auto-generated title.

    Let me know if you need any further information. Thank you!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Rank Math


    Hello @kushalazza

    Thank you for contacting the support and sorry for any inconvenience that might have been caused due to that.

    It seems like an issue on our end and we will get this sorted in an upcoming update.

    We will let you know as soon as we release an update.

    In the meantime, if there’s anything else we can help you with, please let us know. We are here to assist.

    Thread Starter Kushal Azza


    Thanks for the update. Looking forward to it.

    Plugin Author Rank Math


    Hello @kushalazza

    It seems like that the issue is not in the Rank Math plugin but how the new editor, Gutenberg, works with the titles.

    Please check this screencast to understand:

    There’s no title added to the image when an image is inserted in the Gutenberg editor, even though there was a title attribute added to the image when it was uploaded.

    Can you please check on your end if that is the not case?

    Hope that helps. Thank you.

    Thread Starter Kushal Azza


    Hi Team, I just verified at my end. Looks like the issue even exists with the Classic Editor.

    This is probably a bug in WordPress. Even though we have added the title tag, the image is not getting attributed. Hence, when we enable the feature in RankMath, the auto-generated title is being injected.

    Strange! I think it should be reported to the WordPress Core team.

    Anyway, thanks for the investigation. Meanwhile, I have disabled the feature to add the TITLE tags in Images since that can screw up the SEO.

    Plugin Author Rank Math


    Hello @kushalazza

    Thank you for your understanding.

    If it isn’t too much to ask for – would you mind leaving us a review here?

    It only takes a couple of minutes but helps us tremendously.

    It would mean so much to us and would go a really long way.

    Thank you.​​

    Guys I need some help here.

    Google is only indexing the texts on my site.

    It does not index the texts that I place in meta description on Rank Math.

    I use Elementor and Defender plugins.

    Does anyone know what can it be ?

    I have this problem on several sites that use Rank Math. thks.

    Google text: https://prnt.sc/t7n9bh
    page text: https://prnt.sc/t7n9v2
    rank math: https://prnt.sc/t7na6l

    Plugin Author Rank Math


    Hello @leoperiotto

    Please open a new support topic so we can assist you better by following this link:

    Also, 1. First of all, I am assuming that you have already changed the SEO Meta Title and Meta Description with the help of Rank Math:

    Add a Meta Description in Classic Editor: https://i.rankmath.com/dhECkg
    Add title and description in Gutenberg: https://i.rankmath.com/ZO21Cd

    2. Then, ensure that this is the setting in the Schema tab if Schema Markup module is enabled on your website:

    To reiterate, the Schema title must show %seo_title% and the description should show %seo_description% – this will ensure your SEO title and SEO Description that you set up via Rank Math can also be used for your schema details:

    3. The next step is to check if your title/description is properly set up in the page source:

    You can use this tool for the same as well: https://www.heymeta.com/

    4. If it matches your settings, then you must check if Google has seen the changes already or not.

    For that, please check when the Google cache was updated for that page:
    a. https://i.rankmath.com/9q6X0H
    b. https://i.rankmath.com/R8N0Uh

    If the cache date is from before adding the new meta description, then you just have to wait for Google to re-crawl and re-index the page with the new info. If the date is after you made the changes, then you just have to wait it out and there is no further input needed from your end.

    Do note that if everything’s fine and Google still decides to show a different meta title/description for your search keyword, there is nothing you can do as Google sometimes ignores the custom meta info altogether and show something from the page’s content that matches the search intent better.

    Here are some of the common reasons Google might not use the meta description you provided:
    – The meta description is not relevant or useful (ie, just a collection of keywords).
    – The exact same meta description is provided across a large number of pages.
    – The meta description doesn’t match what the user is searching for, but other content on the page does.

    There is a whole article dedicated to this on SearchEngineJournal:

    Here is an example showing Google changes title depending on the keyword used:

    The best you can do is optimize your meta tags to try and match the intent of the search/keyword.

    Hope that helps. If you have any further question(s), please let us know. Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Add missing TITLE attributes issue’ is closed to new replies.