Support » Fixing WordPress » Add Media – Quick Edit – Insert Link not working

  • Resolved callmederek


    Sometime in the last few weeks i have lost several aspects of functionality in my wordpress blog. The things i have found so far that are not behaving correctly all around post management and creation:

    * Add Media button does not work – Clicking it does nothing no response however right click and open in new window and it opens (though with no image thumbnails)

    * Insert link in post edit does not work – dialog opens but will not allow it to be saved and inserts no code into post

    * Quick Edit does noting – no longer expands for quick edit

    * In post edit any section with the “collapse arrow” does nothing

    The things i know i have changed (best of my memory anyway) since all was working is a short list of three things (not that any of them should have issues just tossing it out there)

    * WordPress 3.4 update
    * Shareaholic plug-in update
    * Installed – then removed – MobilePress

    I have searched the forums and found similar reports never with a solution that worked for me.
    I have tried the standard debugging of disabling all plugins, changing to default theme, clearing cache, tired several computers with several browsers with several versions and clearing cache etc. – no luck.

    Thankfully the external site is still working, but administering posts and editing is getting to be impossible.

    Any suggestions would be appreciated as to where to go next.

    Thanks in advance.


Viewing 12 replies - 1 through 12 (of 12 total)
  • It might be of value to know this install has been live and rock solid for some 3 years or more.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Try a manual re-install of the 3.4 files.

    Deleye wp-includes and wp-admin, download a fresh copy from, and upload.



    Forum Moderator

    Have you tried:

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    The PHPMyAdmin trick did it – Thanks!!

    Insert/edit link box and HTML tab not working

    I am using WP 3.4.2 on four sites all hosted by 000WebHost and WP uploaded to them. Three of my four sites work just fine. The fourth and last set up site has the problem of Insert/edit link box and HTML tab not working. This means I have no way to make links from my site. When I highlight text the insert/edit box lights up, but when I click on it nothing happens. When I mouse over the HTML tab the HTML turns red, but nothing happens when I click on it. I only have access to the Visual tab.

    When I drag and drop URLs to the Visual area, the links work just fine. Also the box provision for deleting the link works fine to remove the linking. I had the same negative results before I dragged any links to the page.

    My browser is Google Chrome on Win 7. I’ve re-uploaded WP to with the same mentioned results. The other three sites edit just fine. I started with the 2010 theme and then tried 2011 v.1.4 but the problem remains.

    I might also mention I have added no plugins. All options are as downloaded. However, I did use FTP to rename plugins to plugins.hold with the same negative results.

    I do not have any notice that “allowed memory size exhausted” so never tried increasing the memory available to PHP.

    For me the culprit was Google Maps, of all things. Disabling it restored the Select Files ability.

    Thank you for your response. I downloaded and uploaded to the site WP 3.5 beta 3 and it worked just fine. It was the only solution I could find at the time. I am not using Google Maps.

    I have the same problems as Callmederek. I tried disabling the plugins from PHPmyadmin but no luck…..again I am dead int eh water. Anyone have success with anything else for 3.5? Still no add media ….and I can not add links.

    Hello, i am also having the same problem. I’m only clear on:

    – clearing cache
    – deactivating all plug-ins

    everything else i can’t understand, very limited tech knowledge.

    my site runs on wordpress, and i could easily add posts, insert images previously. i now updated to wordpress 3.5, and suddenly ‘add media’ doesn’t work, when i click, nothing. this is true in pages or in posts.

    please help.

    I’ve tried everything above with no luck.

    Also having the same problem. Using the INSERT/EDIT tool throws me OUT of the page I’m working on and into my POSTS section. WTF?

    I fixed it (in my case) by changing my theme to the default Twenty Twelve theme.

    While using this theme I edited my home page to make sure the INSERT/EDIT link feature was working again – which it was.

    I then changed back to my working theme (Sold!) and it seemed to work OK again.
    I’ll see how it goes form here – and will let you know if the error pops up again.

    This particular theme has a bunch of plug-ins that come with it:
    Background Manager
    Breadcrumb NavXT
    WPML Multilingual CMS
    JigoShop (I’m using Woocommerce)
    and qTranslate

    and it’s possible that any of these could have mucked up my WP install.
    Hope this is of some help.
    [ Signature moderated. ]

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Add Media – Quick Edit – Insert Link not working’ is closed to new replies.