Support » Fixing WordPress » "Add Media" pop up window is blank

  • WordPress : 3.3.1.
    Thesis : 1.8

    This is about the “Add Media” pop up window being blank, and it seems to be a problem which has a lot of people stumped. A solution has been sought several times in this and other forums, but I’ve never seen a definitive solution offered.

    THE PROBLEM: Logged in as an administrator, go to Pages, select an existing page for editing, click on the Uploads/Insert icon/link just above the Editing toolbar, and the media window opens up with the title bar “Add Media”. But that’s all — apart from the title bar, it’s just a blank window with a white background. None of the options for inserting a media file that should appear in that window.

    Searching round the web reveals many people on both Mac and Windows platforms having the same problem, trying all sorts of things, and getting the same results: i.e. no solution.

    * Deactivate all plug-ins — no difference.
    * Changed to basic WordPress theme “Twenty Eleven” v.1.3 — no difference.
    * Uninstalled latest Adobe Flash Player v. — no difference.
    * Installed earlier version Adobe Flash Player v.10.3 — no difference.
    * Upgraded again to latest Adobe Flash Player v. — no difference.

    I think changing the theme proves its not theme related, so Thesis isn’t at fault. And it’s clearly not plug-in related. This seems to be a straight WordPress problem.

    The question is: what could make this happen?


Viewing 6 replies - 1 through 6 (of 6 total)
  • Same here – tried all your gimmicks as well. No result. Even switched the Webserver to Litespeed and back to Apache – no result. Working on a macbook air latest OSX System, all updates, have a nicely configured well performing server setup – it is clearly a wordpress issue! Never had such a major bug before.



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Rosie and carsaig, what browser are you each using?

    I had a similar experience and nothing I tried would remedy it.

    But what I eventually discovered was that although this problem existed in both Firefox 10 and Internet Explorer 8, everything works fine in Google Chrome 17.

    Although I use Firefox more than anything else, and hardly ever use Internet Explorer, I have all three browsers installed all the time for tracking down browser-related problems.

    My suspicion is that the problem is related to the Internet Explorer Rendering Engine.

    Because some version of Internet Explorer is found on all Windows PCs, many application’s developers use the IE Rendering Engine in their own programs, to save having to code their own rendering routines.

    Now whether Firefox uses the IE rendering engine extensively, or whether the association is introduced by a Firefox plug-in, I don’t know. This is just an “educated” suspicion on my part, but I’d like to see the WordPress and Firefox developers take a look at the problem from this angle.

    I now do all my WordPress development in Chrome, and as a result I find myself using Chrome more often for other things that I would otherwise have used Firefox for. So, WARNING MOZILLA: either fix this problem or explain where the real fault lies, or risk losing users to Google Chrome.

    Please respond here if using Chrome solves this problem for you.

    As you suggested I installed Google Chrome and the Add Media thingy works. Looks like I have a new favorite browser.

    For me, I found it to be some lines of code I used in the functions.php to add custom styling to the admin login page. Here is the code. nce I removed all of it, it worked. Page is not that important, so I didn’t break it down to find what line really broke it (don’t have time to do that right now.)

    [22 lines of code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    Hi btdenyer.

    I had never modified functions.php on my blog, so that wouldn’t have been my problem.

    I think Bill Hely is right about it being a rendering thing for most people. It just looks like the editing page is not rendering properly.

    Anyway, whatever the cause, it still works fine in Chrome.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘"Add Media" pop up window is blank’ is closed to new replies.