Support » Fixing WordPress » Add Media not working after 3.5.2 upgrade

  • Resolved singinglawlady

    (@singinglawlady)


    I cannot add media in any of my posts or pages.

    Console in Chrome Browser says there is an error.
    “uncaught typeerror: object [object Object] has no method ‘pointer'”

    Any ideas on how to fix this?

Viewing 15 replies - 1 through 15 (of 22 total)
  • @singinglawlady – When you say that you can’t add media, you’re clicking on the “Add Media” button/link and no window is popping up?

    Yes, that’s exactly what happens. There appears to be an error. What can I do?

    Have you tried another browser? Have you tried clearing your cache and cookies in Chrome?

    @WPyogl – Yes, I deleted all my browsing history/cache. I tried Firefox and Safari. No luck. In the console in Chrome,

    Here is a picture of the error in the Chrome Console: http://bit.ly/132tDpa

    Have you tried deactivating all plugins and switching to the twentytwelve theme?

    I am managing this website for someone, so I don’t want to jack with the theme. Would switching themes mess with the widgets and header images, etc.?

    Switching back and forth between themes can cause issues with a live site.

    One idea you might try is installing the “Use Google Libraries” plugin. Sometimes WordPress and your plugins use different versions of jquery and other libraries. This can cause problems like WordPress windows not opening or admin menu issues. This plugin standardizes the libraries, resolving some conflicts.

    Will this plugin fix the error?

    Do you have any idea why out of the blue the “Add Media” window stops popping up? On my personal site, I upgraded and didn’t have an issue?

    @troy Dunn • THANK YOU!! Installing that plugin fixed my problem! THANK YOU THANK YOU THANK YOU!!!

    Switching themes is a very standard troubleshooting step and it should not cause permanent problems/changes.

    Sounds like it’s something with the theme or plugins on the site in question.

    I can’t say for sure if the plugin will fix the error but it might and if it doesn’t, you can simply uninstall the plugin.

    I don’t know why the “Add Media” window stopped popping up. I know that WordPress updated TinyMCE and I assume this has something to do with it. My guess is that there is a conflict with a version of jqury in one of your friends plugins.

    @troy Dunn • Now the hyperlink button is not working in my posting. When I click on it, the hyperlink window doesn’t come up.

    What is the site in question?

    Try checking for JavaScript errors –

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    @WPyogl • The link to the site is HERE.

    Also, I don’t have FTP access so I can’t edit the wp-config.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Add Media not working after 3.5.2 upgrade’ is closed to new replies.