WordPress.org

Support

Support » How-To and Troubleshooting » Add Media – Insert Image in Post not working

Add Media – Insert Image in Post not working

  • Here’s the problem on a client WP install & particulars:

    Bluehost, running WP2.6.1.
    Initial WP install was done via Fantastico.
    Upgraded to WP2.6.1 using WPAU plugin (today).

    Problem:
    The problem existed before the upgrade to 2.6.1. Upgrade did not change anything in regards to problem.

    We can upload an image, but if you try to insert it into a post, you get a blank screen (both flash or browser method).

    In IE7, there is a error message in the browser status bar, when clicked on this is the message:

    Line: 4
    Char: 1
    Error: Object doesn’t support this property or method
    Code: 0
    URL: http : // client url/wp-admin/media-upload.php?type=image&tab=type&post_id=150

    I have tried the list of things on Otto’s great thread on Image/Media Uploader problems with no results.

    Also, tried another suggestion that included deleting /wp-includes/js directory and reinstalling with fresh code.

    Also, deactivated all plugins, still same problem.

    Any ideas or suggestions are greatly appreciated.

Viewing 15 replies - 16 through 30 (of 44 total)
  • Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    The fact that you’re getting these sorts of errors on fresh installs indicates that you have some kind of common problem between these installs. As in something on your own machine.

    Are you running any funky browser stuff? Strange addons, ZoneAlarm, any sort of firewalls, etc?

    nope. nothing funky.
    WinXP SP3
    McAfee
    -Firefox 3 (all add-ons disabled): whitescreen or login screen error. The error appears to be related to the flash loader. The non-flash loader appears to operate correctly.
    -IE 7 with IE Developer toolbar: javascript error

    I have also tested within a virtualBox running
    WinXP SP1
    No virus protection
    -Firefox 2 (no add-ons): works correctly
    -IE 6: works correctly
    -Safari 3: unable to login

    I had the same problem with Inserting Code into post. I reviewed and did a test and got it successful.
    In Admin panel go to Settings > Miscellaneous
    In Miscellaneous Settings Enable the :
    1. Organize my uploads into month- and year-based folders
    2. Crop thumbnail to exact dimensions (normally thumbnails are proportional)
    .. and saved the Changes. And Now my http://newswing.com is inserting the image code. Here I should clear that my WP version is 2.6.1.

    Guys, try de-activating ALL your plugins, and see if the ‘ADD MEDIA’ buttons & AJAX functionality reappears.

    If they do, (in my case, they did) then start activating your plugins one-by-one until you nab the culprit.

    Form me it was the CFORMS plugin. I upgraded the plugin and averything went back to normal!

    Hope this works for someone else…

    Has anyone figured out what this is related to? I manage a site for someone that has worked great until a couple of weeks ago after an update. What happens is that where you “Add an Image” into a post and a screen generally loads with a darkened background and you get the pop-up screen that has the Choose File tab, Gallery, and Media Library… where you can upload photos and handle the images before inserting it into the post? That pop-up window does not pop up at all. It refreshes the entire page and puts it on a white background in the top left hand corner.

    I’ve done another update for her blog in case some javascript or some other file got corrupted… I’ve also re-downloaded her NextGen Gallery. Now I’ve tried this with all the plugins turned off entirely. It gives the same result with WordPress alone.

    Does anyone have any idea what might be causing this? I am posting this here as well because this sound very much like what is happening with this girl’s photoblog.

    -=- christopher

    Just downloaded the latest version of WP and inserting images in the post still does not work.

    In addition I also think some of the malfunctions are also related to the post editors we use. For example.. I use Editor monkey and Inserting links in the post which the plugin is a pain in the neck.

    Please let us know if there is any solution for inserting images.

    -Abbas
    Technology Nerd

    My problem comes with inserting picture into post…

    The really weird thing is that It actually works when inserting a picture into a page. When inserting into a page I actually get the Flash uploader pop-up. where when I am inserting into a post… I click on the upload photo button and I get sent to the uploader but as a seperate page not as a pop up.

    Does that make sense… Why would it work with the “Write a page” but not “Write a post?”

    I have tried both flash and browser uploaders in posts and pages and Add Media doesn’t work. I get a blank white window after selecting Insert into Post/Page. Support says to upgrade WP application but I am on 2.6.2 now. Any ideas?

    I use firefox and flock and ti’s the same stuff! It’s the same no matter what browser… I wish I could submit my site to be looked at then maybe someone could figure out that the bug is!

    I use Firefox 3.03 I have the same problem. I just find my self looking at a blank screen that would appear to never finish loading. I tried to refresh, never thought I’d say this, but I just can’t get it up!I tried IE7 Same results.

    The problem only started 2 weeks ago for me, and I post regularly. Can’t see any new changes that would have brought this on. I put a placeholder for my images, FTP and link them. I run two blogs, and the problem is the same on both.

    Same problem, WP 2.6.3 , I can upload images, and TN’s are created but when I click the “insert to post” button at the bottom all I get is a blank screen. FF and IE7 both fail, no addons, fresh WP install. There is a real core WP (js?) problem here somewhere.

    Uploader window blank and “frozen” when clicking Insert to Post

    I deactivated all plugins on my site, opened a new article, inserted an image using the uploader, then activated the first plugin on the list, inserted an image, then activated the next plugin on the list, and so on…

    The uploader window stopped working (got blank and frozen) after activating the Custom Field Template plugin (version 0.4.4). Three attemps: bug confirmed (on my installation, at least).

    No other plugin tested today triggered this bug (but I have lots of plugin and have not tested them all yet).

    I have the same problem as above, but only from one of my local computers.
    The computer that has flash 10 on it won’t allow me to upload anything where the laptop with flash 9 still works.

    Could flash be the problem?

    I installed Flash Player 10, and then came across the blank-uploader-window bug, so I searched for it and read that Flash 10 was incompatible with the WordPress Flash uploader — well, it’s clearly not a general incompatibility, since Flash 10 and the Flash uploader are getting along fine on my computer, after I have disabled Custom Field Template.

    If you have the time, deactivate your plugins and reactivate them one at a time, like I did, to test the Flash uploader.

    I’m having the same problem: images upload fine, but clicking ‘Insert Into Post’ results in the white dialog box.

    I’m getting the following Javascript errors in the Firebug console:

    Permission denied to call method Location.toString
    http://whattheh.herald.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20080430
    Line 230

    Permission denied to get property Window.send_to_editor
    http://whattheh.herald.com/wp-admin/media-upload.php?type=image&tab=gallery&post_id=477
    Line 4

    Hope this can shed some light, it seems like a widespread problem.

Viewing 15 replies - 16 through 30 (of 44 total)
  • The topic ‘Add Media – Insert Image in Post not working’ is closed to new replies.