WordPress.org

Support

Support » How-To and Troubleshooting » Add Media Does Not Pop Up – Opens to a Blank White Screen

Add Media Does Not Pop Up – Opens to a Blank White Screen

  • I posted in another forum topic but I think it’s possibly a different (related?) problem so I wanted to post it here.

    Has anyone figured out what this is related to? I manage a site for someone that has worked great until a couple of weeks ago after an update. What happens is that where you “Add an Image” into a post and a screen generally loads with a darkened background and you get the pop-up screen that has the Choose File tab, Gallery, and Media Library… where you can upload photos and handle the images before inserting it into the post? That pop-up window does not pop up at all. It refreshes the entire page and puts it on a white background in the top left hand corner.

    I’ve done another update for her blog in case some javascript or some other file got corrupted… I’ve also re-downloaded her NextGen Gallery. Now I’ve tried this with all the plugins turned off entirely. It gives the same result with WordPress alone. I’ve also cleared out uploads/js_cache folder as per Otto’s suggestion in another post with no effect.

    Does anyone have any idea what might be causing this? I am posting this here as well because this sound very much like what is happening with this girl’s photoblog.

    -=- christopher

Viewing 15 replies - 1 through 15 (of 24 total)
  • Has anyone seen anything like this? Any ideas on what is wrong?

    -=- christopher

    Also I was writing this last night… to be clear it’s not a /blank/ white screen… it’s a entirely new white screen with the contents of what should have been in the pop-up in the upper left hand corner instead of the overlay screen… Just thought I should make that clear

    Got any ad or javascript blockers running? Did you make sure to upload all the files to your WordPress directory, including all the new javascript stuff?

    No it’s definitely not javascript being blocked… I’ve tried it on different browsers, different computers even. I over-wrote every file…deleted everything (including the js_cache contents) Also, I have other WordPress blogs that are working just fine on the same browsers and computers, etc. It had been working fine. I’m really wondering if there could be something in the database causing this somehow. I don’t know enough about what’s stored in there to know if that’s even possible but since I’ve removed /everything/ from the filesystem except the themes and the image content – I even reinstalled her plugins from fresh downloads, mind you – it seems like it almost has to be something hung up in the database. I did notice that NextGen creates several tables. I’m not sure if that interacts with the regular workings of the image uploader/insert media into post functionality, though.

    Any ideas?
    -=- christopher

    anyone?

    Deactivating all the plugins? Any change?

    yeah I even replaced the plugins… it does it when it’s just WordPress by itself, as well. It seems like it must be a javascript problem but I’ve completely replaced and reinstalled WordPress and even cleared the js_cache directory.

    -=- christopher

    sounds a bit like a bug that’s still open at the moment, in case you haven’t seen it:
    http://trac.wordpress.org/ticket/6745

    It does sound similar, but in my our case, the page that normally pops up in in front of the darkened background where you insert the pictures? that part where you would add the photos is on a new blank white page. you can select things and then go to insert them but when you do nothing happens and it doesn’t take you back to the post. Any ideas?

    -=- christopher

    I am having the same problem. I’ve also deactivated all my plugins to make sure the plugins weren’t messing each other up… same problem. I go to add a picture to my post and instead of the screen with the black background I get this white page where I can enter all the info but then the screen goes blank and I cant get back to the original post unless I just completely close the browser and start over. This totally sucks!!!
    I’m ready to pull my hair out!
    Somebody help us!!

    I’m having the same problem it sounds like… except if I go to “Write a new page” instead of “Write a new post,” the photo and media uploader works fine. It just doesn’t work when trying to upload media into a post.

    I’ve also noticed when I go to “Write a new page” the uploader is a pop-up… but when I go to “Write a new post” it’s not a pop up… it just takes me to the uploader as a new page and there is no way to insert the picture into the post. The screen goes blank white after hitting the insert picture into post button.

    tofahd: I hadn’t tried this with a Page instead of a Post because the site’s pages are pretty static compared to posts and I figured it was the same mechanism that is in use in both since they behave identically. I tried it and lo and behold – it works fine when you insert into Pages, just as you said, it’s only in Posts that it has this problem.

    This is definitely a bug. I don’t know the procedure to open a bug report here. Can someone tell me the right way to go about that?

    -=- christopher

    This is a bug. How do we go about making sure it’s in the issue queue?

    The weird thing is… is that I run two blogs… one blog updated just fine… the other one did not… and I did nothing different when updating them. And All the settings should be pretty much identical! And one blog works fine and the other one has this bug!

    This is a bug. How do we go about making sure it’s in the issue queue?

    It already is, the link to it is three posts above yours. That’s what “trac” is.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Add Media Does Not Pop Up – Opens to a Blank White Screen’ is closed to new replies.
Skip to toolbar