Add Media buttons missing, can't upload images through WP (24 posts)

  1. Benjette
    Posted 8 years ago #

    Since upgrading to 2.5, I can no longer upload images through WP. None of the formatting/visual or HTML editor/add media/etc. buttons appear when I go to write a new post, it's just a plain box. My media gallery also has nowhere to upload images. I tried deactivating all my plugins and installing the no-flash image uploader plugin, nothing has worked.

  2. siutouamy
    Posted 8 years ago #

    Does it look like mine?

    I've got two WordPress running 2.5 fine, and I just installed one in another server with 2.5 for someone else, and I've been missing interface. I just downgraded to 2.3, and it still missing the Visual View.


  3. Make sure you read this throughly:

    I have yet to find an installation that was not solved by one of these steps when they were actually followed correctly. The first step alone solves roughly 80% of them.

    Not trying to counter anybody's word or anything, but I've helped people fix countless blogs via email, and the problem has so far always been one of these.

  4. Benjette
    Posted 8 years ago #

    Just now, I have done the following:

    -Re-uploaded all files in wp-admin and wp-includes folders
    -Cleared my browser cache and restarted browser (twice)
    -Installed the latest version of Adobe Flash
    -Disabled plugins one at a time until all were off
    -Inserted the bit of code into an .htaccess file in my wp-admin directory

    And the buttons still aren't appearing.

  5. siutouamy
    Posted 8 years ago #

    I did a clean WP 2.3 install, with a whole new database and it fixed the the whole theme, and was able to see all the visual buttons. I just upgraded to 2.5, and seems to work better... but I still can't see the visual mode, even though it's activated.

    Browser cleaned twice.

    Though I don't think it's the browser because my first two WP running versions are running fine.

    Disabled the plugins.

    and the htaccess file.

    Could it be their server? Is there like a slim chance that it's that?? Anyway, doing a clean clean install of 2.5 now.

  6. siutouamy
    Posted 8 years ago #

    Did a 2nd install of WP 2.5, clean clean... new database and all. It worked! I had the complete interface, but minutes later when I was uploading media, it gave me a 500 Error. TT

  7. Benjette
    Posted 8 years ago #

    No offense siutouamy but please keep your updates to your own thread, as my problem is still not resolved.

  8. Benjette: Do you have the visual editor enabled? Check the Users->Your Profile page.

  9. Benjette
    Posted 8 years ago #

    I don't normally have the visual editor enabled because it always messes up the formatting of my posts if I try to edit them (using Firefox on a Mac).

    I just turned it on, and when I went to Post New, I couldn't even see the regular formatting buttons anymore, let alone the media buttons. When I try to click on Visual or HTML, nothing happens either time.

  10. Well, the media buttons are only in the visual editor. So that's definitely part of the problem. Now you need to work out why the visual editor isn't working for you.

  11. Benjette
    Posted 8 years ago #

    So you're saying with 2.5 I can't upload images through WP without having the visual editor turned on? Sounds like a step backwards from previous versions.

    Anyway, any suggestions as to why the visual editor isn't working?

  12. So you're saying with 2.5 I can't upload images through WP without having the visual editor turned on?

    No, my mistake. The visual editor is not required, the add media buttons show up even when the visual editor is off. I just tried it:

    Have you disabled your plugins? All of them? I had the media buttons disappear from my site when I had an old version of WP-Amazon loading.

    But any plugin using Javascript might interfere with the appearance of those buttons. If you have javascript disabled, they won't show up. If you have an adblocker interfering, they might not show up. There's a dozen things that can break the editor, I don't know which one applies to your case.

  13. Benjette
    Posted 8 years ago #

    Oh, phew. Because I hate the visual editor.

    When I do have it enabled though, when I go to Post New, it appears to be in "Visual Editor" mode (though it looks no different in the box than when it's off), and when I click on HTML, nothing happens at all.

    Just to clarify, there are NO buttons appearing - not just the Add Media buttons are missing, but also the regular formatting buttons. It's a plain box no matter what else is enabled. So I'm not so sure it's the visual editor that's broken as it is something else entirely.

    And I have tried deactivating all of my plugins again to no avail (I only have 4 extra).

  14. Benjette
    Posted 8 years ago #

    Any thoughts?

  15. Are you getting any javascript errors in the error console when you load the write page? Firefox->Tools->Error Console.

    Note that I only need javascript errors, not all the CSS warnings and such.

    Try deleting anything you have in wp-content/upload/js-cache.

  16. Benjette
    Posted 8 years ago #

    I don't have a js-cache folder

    This is the only error appearing:

    Error: f has no properties
    Source File: http://retardedinlove.com/wp-includes/js/tinymce/tiny_mce_config.php?ver=20080327
    Line: 37

  17. ...

    Well, that really doesn't make any sense at all.

    Sorry, but I have no idea how to fix your issue. All I can suggest at this point is checking permissions, looking at the *.js files being loaded by the page, and trying to figure out what's not loading properly.

  18. kubrick30
    Posted 8 years ago #

    I experienced this issue with the Add Media bar above "write post" being absent. At first glance, it appeared as though 2.5 had implausibly done away with image upload!

    I was clued in by the comment that said 80% of these issues are resolved by following the instructions provided in the included link. I tried removing wp-admin and wp-includes and replacing them from a freshly downloaded copy of 2.5, and deactivating plugins. This did not help. Then I realized I had only tried firefox. In IE, the Add Media buttons were present. So I cleaned out the cache in Firefox, and that fixed it.

    Incidentally, in the Firefox error console, suggested above, there were several critical javascript errors generated by loading the "write post" page (something about Jquery, have forgotten details), which disappeared after clearing the cache.

  19. etegration1
    Posted 8 years ago #

    after upgrading to WP 2.6, i have the same problem. what gives? media toolbar is missing. i upgraded 5 more sites of WP to 2.6, no problem. only 1 particular sites. all using the same source 2.6 files.

  20. mazedlx
    Posted 7 years ago #

    i found out that a plugin was the cause for the media buttons to disappear. after some trial and error i've found out that Customize by Julien de Luca, breaks the media buttons. this plugin is only used to customize the freshy2 theme designed by Julien de Luca, deactivating it brought the media buttons back. hope that this helps you.

  21. za3tar
    Posted 7 years ago #

    mazedlx, thanks for your help. I was having this problem for quite some time, and disabling Customize fixed the problem for me.


  22. rotello
    Posted 7 years ago #

    Thank mazedlx...

    "Customize" plug ins by Julien de Luca and Wp 2.6 does not match...

  23. egdotcom
    Posted 7 years ago #

    I too am having problems with 2.6.1 and no media buttons.
    I am a newbie to WordPress and was going spare as I just couldn't find a way to upload files and couldn't find a plug in to do the job.

    I have done a fresh install via Fantastico on another site - no plugins, no additional templates - straight install. Still no buttons.

    Should I just give up?

  24. egdotcom
    Posted 7 years ago #

    OK - all solved.
    As a newbie I was expecting that under Media Library, I would be given buttons to upload etc. Reading the forums, I felt this to be true.

    Luckily, after numerous reinstalls, I found an official wordpress demo and that too had the same problem. This led me to think that if it appears WP can't get it right, then perhaps I am looking for wrong things.

    Then I found the magic line in the manual that told me to upload media through write pages/posts. All solved for me!

    A little illogical for me but now one happy bunny. Now I can add all those marvellous plug-ins again!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.