Support » Fixing WordPress » ADD MEDIA button not working (sometimes!)

  • Resolved matthk


    Hi, my ADD MEDIA button refuses to work (i.e. I click, and nothing happens) on SOME of my pages.

    It seems (I could be wrong) that it’s a template issue within my theme Sold! by Parker & kent

    Here’s what happens:
    (1) ADD MEDIA button works on new pages.
    (2) ADD MEDIA button stops working when I apply one of the page templates that came with my SOLD! theme to any new page.

    Any ideas?
    I’m not a PHP pro, I’m just an old school HTML designer from back-in-the-day.
    I’m hosting with HostNine so have cPanel, but am none too fluent with it!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Did you try a different web browser? If it is safari or an old version of a browser sometimes there are issues with that.

    Thanks, ifcure08.
    Yep, tried three broswers – all are up-to-date.
    It’s not a browser issue though, it’s a WP issue. 🙁

    ahhh then it could be the theme – I know some complex themes override things or can cause issues – I am not familiar with that theme.. I would start there 🙂

    ah….. yep…. that’s a given – sort of.
    Most likely, it’s one or more, of four things:
    (1) WordPress
    (2) The theme
    (3) a plug-in issue
    (4) Something at my host (HostNine)

    What I’m after is a workaround, a fix or input from someone who’s had the same (or similar) problem and solved it. Or a WordPress staffer who can tell what’s going on.
    Suggesting I ‘start’ with the theme simply isn’t practical. Am I supposed to hack into the entire theme code? Am I Steve Wozniak? If I had mad coding chops, I’d not be asking questions here. I’d have fixed it long ago and would be answering questions instead. 😉

    WHAT I’VE DONE SO FAR – (which hasn’t worked)
    (1) adding define('CONCATENATE_SCRIPTS', false ); to the bottom of my wp-config.php file (just before the require_once line).

    (2) Switching my theme to one of the basic WordPress themes.

    (3) Turning off ALL plug-ins.

    It’s been suggested that one fix (at least with my theme Sold!) is to replace the Options-tree directory with an updated version:

    Am in the middle of trying this – the button works, but now the theme seems to be slightly broken 🙁 i.e. I can’t get the sliders to work.

    Hmmm…. Didn’t work with the existing pages that I’d applied the slider templates to, but it worked FINE when I created a new page. Interesting. So, there you have it folks, for those who are having this issue while using the SOLD! theme by Parker & Kent, the ‘options-tree’ solution above may be your workaround.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘ADD MEDIA button not working (sometimes!)’ is closed to new replies.