Support » Fixing WordPress » Add Media button not working

  • I cannot add images into my blog posts. I have tried everything. I have deactivated all plug ins, I have emptied my cache, I have restarted my computer. Multiple buttons in my back end of wordpress arent working when I am in the posts tab trying to create a new blog post. Add media doesnt do anything, Select recent tags doesnt do anything, I cant view the TEXT editor at all, I am unable to insert any images into my post whatsoever. PLEASE HELP

Viewing 15 replies - 1 through 15 (of 15 total)
  • You may have javascript disabled on your browser. Google how to turn that off based on which browser you use.

    All of the things you are mentioning work with javascript.

    It worked a few weeks ago. Nothing on my browser or computer itself has changed since then. I have also tried to do it on multiple computers where the javascript was working correctly and still same problem 🙁

    Try switching back to the default 2012 theme. If that clears it up, you know it’s an issue with your current theme. Maybe they’ve released an update?

    Have you tried activating a different theme? I know if the site is not in demo that is not always possible, but it is the best way to see if it is a theme-related issue.

    I have had the same theme for over a year without any issues. I just posted a blog a few weeks ago without an issue. I haven’t dont anything to my theme. I have a custom Theme Forest website theme that I love, I don’t want to go to a default theme, It does not work for my professional business. I can’t see how it would be my theme if it’s been fine all this time and just now it stopped working. It seems like a wordpress platform problem. My theme itself is working perfectly.

    In the wordpress back end and dashboard there is a tab at the bottom where my theme is kept… the name of my theme is CORE.. when I go into my actual theme preferences everything works perfectly… it’s when I am working on a blog post through the normal wordpress dashboard where the buttons arent working at all. It seemed like things were fine before I updated to the new version of wordpress…

    Many themes had javascript issues that were exposed when WordPress released 3.5(.1). Without getting into the technical reasons it is indeed an issue with the theme. Have you checked to see if they’ve released an update (I bet they have)? You should also go to them for support as you paid for it when you bought the theme.

    Going to the default theme is a standard troubleshooting step to see if there is something in your theme impeding the new version of WordPress that you just installed. It doesn’t mean you have to stay with the default theme, but if you want to fix things, this is a necessary step.

    Basic troubleshooting, for your reference, involves ALL of these steps:

    • flush any caching plugins you might be running, as well as server and/or browser caches.
    • deactivate all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Sometimes, an apparently inactive plugin can still cause problems.
    • If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin (read if you need help).
    • switch to the Twenty Eleven theme to rule out any theme-specific problems.
    • If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.
    • manual upgrade. When all else fails, download a fresh copy of the file of 3.5.1 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first:
    • check the Master List to see if you’re experiencing a known issue:

    Usually, things just don’t “stop” working. Something happens, even the slightest change, that triggers an issue. The WordPress files just sit there. However, both themes and plugins can interact with the core files which can cause issues. (Malware also affects files keep in mind)

    You have to retrace every single change including updating your theme, wordpress, plugins, touching the file editor, etc.

    Can you provide a link? Maybe there is something on the front end we can see?

    Im a photographer not a web designer or programmer so sorry if I seem a little ignorant lol 🙁 I am not familiar with how to get deep into any files or understand how the code or editor works. So a lot of that is a different language to me. I never changed anything with my theme at all. All I ever do is post blogs or add images to my galleries and in the past month I have only posted one blog post and everything worked smoothly so that’s why I am so confused when I went to post images today and couldn’t.

    And a great photographer you are. Nice pics.

    You happen to have a lot of javascript files included(from plugins). It is normal to have many, but this is quite a few. That’s ok, but the thing with javascript (or jQuery) is that when there are a lot of uses, sometimes there is a name conflict somewhere or a version conflict. (jQuery runs most of your special effects and has core files, which like WordPress, gets updated.)

    All it takes is one and when that error is thrown, regardless of which file does it, everything suffers.

    Are you sure you deactivated all the plugins?

    That’s all I can think of?

    You really need to check the theme, dude. Switch to twenty twelve, see if you get the same behavior, and then you can switch back. All of your settings will be kept intact in your database, and that goes for plugins, too. If it is an issue with the theme, you’ll know, and you can contact the developer. If it’s not, then you’ll have ruled that out.

    i use js-restaurant plugin in wordpres.when this plugin is activate add media button not work what is the solution?

    please help
    thank you



    Forum Moderator

    @kalpesh_rank: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem is likely to be completely different.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Add Media button not working’ is closed to new replies.